Results 1 to 9 of 9

Thread: Zoom files missing error - but they're there

  1. #1
    Join Date
    Nov 2005
    Posts
    4

    Default Zoom files missing error - but they're there

    I'm trying to test an installation of Zoom, but I Keep getting the following error.

    Zoom files missing error: Zoom is missing one or more of the required index data files.
    Please make sure the generated index files are uploaded to the same path as this search script.

    The files are in the same folder as search.php, and I used the Indexer to upload them. None of the files have been modified.

    Any ideas?

  2. #2
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    4,229

    Default

    This error message is produced when one or more of the files are missing.
    settings.php
    zoom_wordmap.zdat
    zoom_dictionary.zdat
    zoom_pages.zdat
    zoom_titles.zdat

    Can you post the URL to your search function so that we can see the error.

    ----
    David

  3. #3
    Join Date
    Nov 2005
    Posts
    4

    Default

    Yeah, I looked at the code in search.php to see what would cause that error, and those files are there.

    http://www.anythingtruck.com/search/search.php

  4. #4
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    3,737

    Default

    Have you modified the search script (search.php) in any way? Any changes you may have made may have broken the functionality of the script.

    There also seems to be something strange happening at:
    http://www.anythingtruck.com/search/
    It returns a 403 Forbidden error, which is reasonable, but also delivers a file with an "application/x-miva" content type. If there is any server-side redirecting (or URL Rewrite) setup for this folder, let us know, asi it may be affecting the way that PHP is locating files.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

  5. #5
    Join Date
    Nov 2005
    Posts
    4

    Default

    Nope. No modifications to any files. I only opened my local copy of search.php to see what would cause the error.

    You're seeing the 403 and "application/x-miva" because there is no index.html file in the search folder and all html files on our site are being processed as dynamic pages using Miva Script's language processor.

    No redirects or rewrites.

    On another note, I have installed the cgi version and it is running okay. I went with the php version first because I figured it would be nice to have more ability to change the look and feel. I am still curious why the php version is not correctly running though.

    Thanks.

  6. #6
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    3,737

    Default

    The PHP problem sounds like a server configuration issue. If you are familiar with PHP, you can try some tests and see if file_exists() is failing to locate files in the same directory. For example, if there are the files "test.php" and "test.txt" in the same directory, and test.php contains the following:

    Code:
    <?php
    if &#40;file_exists&#40;"test.txt"&#41;&#41;
        print&#40;"ok"&#41;;
    else
       print&#40;"something's wrong"&#41;;
    ?>
    Then it should let you know if this is the case. There are some older versions of PHP which had reported bugs with file_exists() when PHP is running in safe mode, and various other issues. Perhaps you can check which version of PHP you are using. You may also have various non-default settings configured for paths. We are unfamiliar with Miva Script and are uncertain if this could cause any conflict as well.

    If you want us to pursue this PHP issue further, you can e-mail us, and give us temporary FTP access to your server. We can do some tests and confirm the cause of the problem for you.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

  7. #7
    Join Date
    Nov 2005
    Posts
    4

    Default

    Thanks for your help. I did try the test that you suggested and it failed too.

    I'm going to stick with the cgi version. It is working well, and I'm very happy with it after just one evening of adjusting the indexing settings and the look and feel through the template. Now I'm off to purchase the Pro Edition.

    Thanks,
    Todd

  8. #8
    Join Date
    Jun 2010
    Posts
    1

    Default

    I am having the same issue, but for the life of me i cannot make the engine reproduce these files:
    zoom_descriptions.zdat
    zoom_pagetext.zdat
    zoom_pages.zdat
    zoom_titles.zdat
    Any idea as to why they are not regenerated?
    Version 6.0 ------------Thank you

  9. #9
    Join Date
    Dec 2004
    Location
    Sydney
    Posts
    4,229

    Default

    You posted this in the V4 forum.

    V6 of Zoom produces a different set of files. Files like zoom_titles.zdat are no longer required by the V6 script, nor produced in V6 of the indexer software.

Similar Threads

  1. Missing zdat files?
    By tschenz in forum Zoom Search Engine V4 (Old Version)
    Replies: 5
    Last Post: 05-29-2006, 12:08 AM
  2. Error: Can not find one or more of the Zoom index files
    By florante in forum Zoom Search Engine V4 (Old Version)
    Replies: 2
    Last Post: 12-13-2005, 03:49 AM
  3. Why doesn't Zoom search my Forum (.htm files)?
    By Anonymous in forum Zoom Search Engine V4 (Old Version)
    Replies: 1
    Last Post: 07-28-2005, 09:19 PM
  4. Zoom config error: The zoom_datetime.zdat file is invalid or
    By Anonymous in forum Zoom Search Engine V4 (Old Version)
    Replies: 1
    Last Post: 06-27-2005, 11:50 AM
  5. Zoom config error: The zoom_datetime.zdat file is invalid
    By nielsencl in forum Zoom Search Engine V4 (Old Version)
    Replies: 1
    Last Post: 01-03-2005, 05:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •