Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.


No announcement yet.

502 error with cgi version on IIS7

  • Filter
  • Time
  • Show
Clear All
new posts

  • 502 error with cgi version on IIS7


    I'm trying to run the cgi version of Zoom on IIS7 (Windows Server 200. I read this http://www.wrensoft.com/zoom/support/faq_cgi_iis.html carefully and followed the steps twice. It caused a 500 internal server error.

    I asked my hosting company for assistance, and I think they went in and removed the CGI module mapper (there was another one in place already, I think for Perl), which now results in a 502 error - Web server received an invalid response while acting as a gateway or proxy server. They also gave me a little more information from the error logs:

    HTTP Error 502.2 - Bad Gateway
    The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are "Unrecognized character \x7F; marked by <-- HERE after <-- HERE near column 1 at [removed filename] line 1. ". Detailed Error Information
    Module CgiModule
    Notification ExecuteRequestHandler
    Handler CGI handler
    Error Code 0x000000ff
    Requested URL [removed URL]
    Physical Path [removed path]
    Logon Method Anonymous
    Logon User Anonymous
    Most likely causes:
    •The CGI process was shut down or terminated unexpectedly before it finished processing the request.
    •The CGI process has a flaw and does not return a complete set of HTTP headers.

    They think it is a header issue. I did play around with the timeout numbers, and that had no effect.

    Have you encountered this before? Do you know how I can fix this? I'm still pretty new to IIS7 and Windows servers in general. The same script runs fine in Apache.

    Thanks in advance.

  • #2
    I think the server is still setup to execute the CGI script as a Perl script.
    So Perl tries to execute the binary CGI, then fails complaining about bad Perl code, and the server then doesn't get a valid set of headers back, and throws the error above.

    This is also covered in our FAQ
    Q. I get an error similar to "Unrecognized character \x90 ... "


    • #3
      Thanks. I tried renaming the file extension to exe and loading it. A Windows dialogue pops now that says "You have chosen to open search.exe. Would you like to save this file?" with the options to save or cancel.

      I will contact my hosting company again for further advisement... Earlier, I did attempt temporarily removing the Perl cgi handler and leaving the other one but that did not work for me either.

      The FAQ you directed me to has a link to a Microsoft knowledge base article, but that link appears to be broken and results in a 404.

      If you have more recommendations, I would be happy to hear them

      Thanks again.


      • #4
        The MS knowledge base article
        only referred to IIS5 and IIS6. I don't think it applies to IIS7.

        There are details, with screen shots here, showing how to setup CGI on IIS7


        • #5
          Oh, OK. Yeah, I did the CGI setup as shown in that FAQ...

          I was reading through some of the other posts, and it occurred to me that maybe I set up Zoom incorrectly. I just took what was running on Linux and tried to put it on IIS7. I noticed in another post that there is apparently a CGI/Windows version... In my version of Zoom V6, I see the "CGI/Linux" option (what I used) but I don't see CGI/Windows.


          • #6
            Oh, wait. I just saw it pop up with the platform option.

            Going to try this over from the beginning.

            Thanks for your patience.


            • #7
              No, still have the same problem.... oh well.


              • #8
                Yes, there are 3 versions of the CGI. Linux, Windows & Unix. (and actually we have a Mac and Solaris version as well).

                The Linux version won't work on a Mac.

                If we could have full access to the server, I am sure it would be fairly trivial to fix. But you are unlikely to get full access if you are on shared hosting.


                • #9
                  I actually just got it to work!! Thanks for all your patience and help.