System Requirements

There are TWO main components to a search engine: indexing and searching.

  1. For indexing your website, you will require ONE desktop or server computer running either: Windows, Mac, or Linux. Click on one of the following or scroll below:

  2. For searching your website or CD/DVD,

    Your requirements will depend on the scripting platform of your choice. You will need any one of the following:

    • Web server with PHP (4.2 or higher) installed (see PHP option) OR
    • Web server with ASP 3.0 or higher and VBScript 5.5+ installed (see ASP option) OR
    • Web server with CGI executable permissions (CGI option) OR
    • Web server with ASP.NET support (hosting permission and Full Trust privileges to install and run custom Server Control - see ASP.NET option) OR
    • A web browser with JavaScript 1.5 or higher support (Javascript option) - when none of the above is available.

Zoom Search Engine Indexer for Windows

  • Windows Vista, Server 2008, Windows 7, Server 2012, Windows 8 or Windows 10.
  • 128 MB of memory (more memory is required to index larger sites)
  • At least 50 megabytes of available disk space

For users on Windows XP (SP2 or later) and Server 2003, you can still use V7.0

Zoom Search Engine Indexer for Mac

  • Mac OS X 10.7 or higher
  • 128 MB of memory (more memory is required to index larger sites)
  • At least 30 megabytes of available disk space

Zoom Search Engine Indexer for Linux

If you are on shared hosting, it is recommended to create the index locally using the Windows or Mac version. The search scripts to run on a Linux based web server come with all versions of Zoom.

Zoom for Linux is generally only recommended for advanced site admins, i.e. if you have dedicated hosting and need to run the indexer directly on the web server.
  • 128 MB of memory (more memory is required to index larger sites)
  • At least 30 megabytes of available disk space
  • Web server with PHP (5 or higher) installed
  • PHP needs to support shared memory (compiled with --enable-shmop)
  • Permission to install and run binary executables on the server.
  • glibc 2.12 or higher recommended
  • libcurl 7.19 or higher recommended
  • UTF-8 support requires "en_US.UTF-8" locale

Please note that Linux distributors may provide packages for your distribution which have different requirements. Zoom Indexer will not run at all without the above libraries or packages.

Go back to the main page to find out more about Zoom.