Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Cache problem between different CD

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cache problem between different CD

    Hello,

    I created a few CD with our registered version of Flying Ant CD Server and Zoom Search.

    When I swap from a CD to the other (between French and English for example), the content of the last Cd is always shown instead of the inserted CD!
    I always have to hit Ctrl-F5 to refresh the content and see the actual one...
    This is a big problem for someone surfing the CDs I,ll be creating!

    How can I make sure the content is refreshed all the time? Anyone else have tried this?

    I have tried to include code that force refresh but it doesn't seem to work. It doesn't do that if I browse the CD without activating the Flying Ant server.

    Thanks in advance for your help!

    Kevin

  • #2
    Hi Kevin.

    Getting browsers to refresh a URL reliably can be tricky. What often may work on one browser may not work on another.

    However, one way to likely avoid the issue is to change the open_url (in your flyingant.conf file) to be different from CD to CD.

    You can do this without renaming the home page file, you can simply add some HTTP GET parameters at the end of the URL (which will be ignored anyway).

    For example, if your current open_url setting is:

    open_url http://127.0.0.1:8091/index.html

    You can change this so that the English CD has:

    open_url http://127.0.0.1:8091/index.html?lang=en

    And the French CD has:

    open_url http://127.0.0.1:8091/index.html?lang=fr

    The parameter itself is actually ignored by the web page, but it enforces the browser to attempt a refresh because the URL is different. Hope that helps.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Hello,
      i had the same problem that could be solve (even) with:
      <META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">
      in the head section.
      Regards
      Schluej

      Comment

      Working...
      X