Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

"Warning: unpack() [function.unpack]" Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Warning: unpack() [function.unpack]" Error

    When submitting certain words ("tim", "mike", "find", and other random words) to the search, a repeated error message ("Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 1 in /home/byttrot/public_html/clients/regester/includes/search.php on line 1019") fills the results page before the results are finally shown after about 100 pages of scrolling.

    So far it is only a handful of words that throws up this error, but these words don't appear to be in any way different to the words that work fine.

    I have tried changing the character encoding settings, and nearly every other option in the Zoom Indexer, but the only thing that appears to change is which words the script gets caught up on (it changed from "tim" to "mike" inexplicably last time I re-indexed the site).

    If anyone has any experience of this error message, or a similar problem to mine, any information or suggestions would be greatly appreciated.

    Thanks in advance,
    Dan

  • #2
    The most likely causes of your problem are:

    1.) You have not re-uploaded ALL the required files after your recent indexing, and you have a mix of old and new index files on your server. Make sure that all the files listed at the end of indexing (under "Required files") are uploaded and allowed to overwrite the old files. If you use the built-in FTP feature in Zoom, this would be ensured and you should not have this problem.

    2.) You have uploaded the search files using text/ASCII mode with a third party FTP client. Make sure to upload the files in BINARY mode. Do not rely on any "Automatic" mode as many FTP clients guess this wrong. Again, we recommend using the built-in FTP feature in Zoom as it would ensure that this wouldn't be a problem.

    3.) If you have modified the PHP search script you are using, you may have accidentally broken functionality. Note that you should not modify any of the index files generated by Zoom, this includes the "settings.php" file.

    If you continue to have this problem having checked all of the above, let us know what version of Zoom you are using (click on "Help"->"About").
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Thanks for your reply Ray. I re-indexed everything and re-uploaded in binary mode and the problem has been fixed!

      I'm not sure whether this was due to some files not being overwritten, or because some files were automatically being sent in ASCII mode... Either way, it works now.

      Thanks!

      Comment


      • #4
        I have the same problem. ("Type v: not enough input")
        I upload with Zoom, so that should not be the problem.
        I have version 6, so that shouldn't be the problem.
        What else can it be?

        Comment


        • #5
          Highly likely the index is corrupted. The reasons Ray listed above are the most common causes.

          If re-indexing doesn't solve it, zip up your set of index files and either Email them to us, or put them on a your server so we can download them. We can then try your files on our server.

          Comment

          Working...
          X