Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

FTP upload hangs or stops while queuing files for upload

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FTP upload hangs or stops while queuing files for upload

    Here is a question and answer that might help some other people.

    Q. The FTP function in Zoom hangs up after opening the connection. The message states that the software is queuing the files for upload…and hangs up, at about 50 bytes of data.

    A. The problem is most likely the PASV setting. This setting controls who acts as the server and who acts the client in the FTP connection. PASV (passive) mode was designed for clients behind firewalls and will be required for some hosts. By default Zoom attempts a FTP connection in Active mode (Zoom acts as the server).

    You can force passive mode, by checking the PASV box on the FTP tab in the Zoom configuration window. Toggling this setting and attempting the upload again (from the tools menu in Zoom) can often solve the problem.

  • #2
    This is a problem that arose for me some months ago, and indeed using PASV made it work. But I don't need to use PASV with my regular FTP client (Cute FTP), which seems to suggest the FTP server doesn't require it. Any idea why ZoomSearch's FTP is an exception?

    thanks,

    james

    P.S. I just upgraded to 5.0, and it's fantastic. Thanks for your great work.

    Comment


    • #3
      Yes, in response to that support query and several other people who had FTP issues, we almost totally re-wrote the FTP upload function for V5.

      At the time (mid 2006) we thought the FTP function was OK in V4. But as with many things in IT, the closer you look the more flaws you see.

      V5 should be more reliable and work more consistently with a wider range of FTP servers than V4. So you might try turning PASV mode off again if you have just switched to V5. (Not that there is any great benefit to having it off or on).

      Comment


      • #4
        Actually, I tried V5 first with PASV off, hoping that the old problem had been resolved, but it still didn't work. Then I looked on the forum and found this solution.

        So, at least in my case, it still hangs unless I use PASV, though I don't have to use it with my regular FTP client.

        It's a perfectly fine workaround, but I suppose you would want to know the problem is still out there.

        Comment


        • #5
          Let me know if you want any details on my hosting or configuration to look into it further.

          Comment

          Working...
          X