Home » Forum

Announcement

Collapse
No announcement yet.

Scheduler Error 0x4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scheduler Error 0x4

    I cannot get task scheduler to complete Offline Indexing. Win2k Server.

    Although it runs it returns a last result of "0x4".

    Any ideas?


    Cheers

    Tox

  • #2
    First, try the latest build (4.0.1013) available from here:
    http://www.wrensoft.com/zoom/whatsnew.html

    If you continue to get this problem, can you give more information:
    - When exactly do you get this "0x4" error? Is it after you create a schedule task, or after the scheduled task executes (at the end of indexing?)
    - Can you give us the exact error message you see (if possible, make a screenshot). Does it say something like "Access violation ... "?
    - What version of Windows and Internet Explorer are you using?
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Currently using 4.0.1012

      The "0x4" error is the last result from the sceduled task.

      i.e. If you open the task scheduler and view the details of the task the "Last Result" says 0x4. Neither the indexes or the php files are updated.

      Unfortunatley scheduler seems to be the most useless program for debug.

      The log has the following message :

      "Zoom Scheduler - zoom.zcfg (Offline indexing) - TaskID 20050302153552.job" (ZoomIndexer.exe)
      Finished 02/03/2005 18:57:23
      Result: The task completed with an exit code of (4).

      When I run the config file from the program there are no problems.

      The indexing software is running on Win2k Server SP4 with IE 5.

      The intranet server is FC2 with Apache 2.0 + PHP 4.3, there are no problems searching or displaying.

      Hope this gives more info.

      Cheers

      Tox

      Comment


      • #4
        Oh I see, you meant the Windows Task Scheduler. This is an exit code from the Indexer, and is used to indicate that the indexing failed (usually because no files were found to index).

        One possibility is you may have mistakenly scheduled the indexer to use Spider mode (you specify the mode when you click "Add task") and you had no valid spider indexing options set (since you intended to use Offline mode, as you said before). If this is the case, remove the scheduled task, and create a new one, making sure you specify to use "Offline mode" in the "Add task" window.

        You can also confirm what happened from the "zoomindexer.log" file found in you Zoom program folder. This will contain the index log from the last scheduled session.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Apologies, I did mean windows task scheduler.

          I got it working thanks.

          The log file told me the output directory didn't exist which was a permissions issue.

          Thanks for your help.


          Tox

          Comment

          Working...
          X