Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Indexing .desc Files When Using Database

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Indexing .desc Files When Using Database

    Hi,

    My .desc files are not being indexed.

    I have configured IIS to allow .desc files. I have added the .desc extension to the Scan Extension, Scan Options list (not sure if I needed to), I have selected the Use Description (.desc) files for PDF files, I have ensured that Meta description and Meta keywords as well as hyphens are selected (found out that you need that somewhere on this forum) from the Indexing Options tab.

    That being said, the associated PDFs are not directly referenced on any page as they are kept in a database and listed on the page as the result of a query when the page in question is opened. The page does refer to the path that the files are kept in, so I would have thought that indexing would work on .desc files. The pdf and .desc are in the same path. The pages that refer to that path are being indexed properly.

    I am using Spider Mode.

    I don't know what I'm missing...

    Thanks,
    Julie

  • #2
    I have added the .desc extension to the Scan Extension list
    There should never be any need to do this.

    I have ensured that Meta description and Meta keywords as well as hyphens are selected
    There is no need to select hyphens as a join character to get .desc files to work. They are two independant settings.

    Can you tell us,
    1) What would be an example of a URL that references one of your PDF files.
    2) What is the full name and path of the corresponding .desc file?

    Comment


    • #3
      An example of a URL where the code queries the database to obtain the PDF file name and other file attributes and displays them on the page is:

      http://msvintradev:8090/departments/it/departments-it-ops-private-admin.cfm

      Note that the msvintradev:8090 is the name of our development website with its port.

      The PDF is called:

      The File Name.pdf

      The associated .desc is called:

      The File Name.pdf.desc

      Thanks,
      Julie

      Comment


      • #4
        The the URL doesn't contain the name of the PDF file there is no way for Zoom to associate the .desc file with the PDF file.

        Comment


        • #5
          Since your PDF files are not served directly, but via a CFM script, there's no obvious way to reference a .desc file (if you recall, the .desc files are expected to be in the same folder/location of the PDF file - but the PDF file isn't actually located in any folder in your scenario - it's really in your database).

          What you should do is look at the "Use this offline folder for all plugin .desc files" feature under the "Scan Options" tab of the Configuration window. You can then specify an offline .desc file to use with a specific URLs. Click on "Help" on that window for more information.
          --Ray
          Wrensoft Web Software
          Sydney, Australia
          Zoom Search Engine

          Comment


          • #6
            Hello again,

            Just a quick correction - my pdf and all other file types are saved in the same directory on the server.

            I have done what you have suggested, that is, put the file path as part of the .desc file name, using the proper encryption, and I have selected the "Use this offline folder for all plugin .desc files" feature of the search engine and my .desc files as well as all original files types (.doc, for example) which do reside in the same directory, are not being indexed.

            Thanks again.
            Julie

            Comment


            • #7
              So what do you new URL's look like? Or are they the same?
              What are the file names of the .desc files?
              And what do you have entered into Zoom in the "offline folder for .desc files" field?

              Comment


              • #8
                Hi,

                Note that I am storing the .doc in the database, but that the .doc is also saved to the file structure along with it's associated .desc. The .desc is not stored in the database.

                One of my URLs is:

                http://msvintradev:8090/departments/it/departments-it-ops-private-admin-form.cfm?id=252&intCategoryID=1&strDesc=&fileName= Full_Domain_Name_and_URL_Path.doc

                The file names is: Full_Domain_Name_and_URL_Path.doc

                It's .desc is:
                msvintradev%5Cprivate%5Cit%5Cops%5CFull_Domain_Nam e_and_URL_Path.doc.desc

                The path where both files are uploaded to is:
                C:\Inetpub\wwwroot\msvintradev\private\it\ops\

                In the Zoom "offline folder for .desc files" field, I have:
                C:\Inetpub\wwwroot\msvintradev\private\it\ops

                Thanks,
                Julie

                Comment


                • #9
                  I forgot to mention that the file name appears in the URL I have pasted below when the user selects 'Edit' placed by the file in question. When the user chooses to only diplay the list of uploaded files, the URL does not display a file name since all files uploaded by the user to the server are displayed on the page.

                  Hope that bit of information helps.

                  Julie

                  Comment


                  • #10
                    Originally posted by juliep View Post
                    One of my URLs is:

                    http://msvintradev:8090/departments/it/departments-it-ops-private-admin-form.cfm?id=252&intCategoryID=1&strDesc=&fileName= Full_Domain_Name_and_URL_Path.doc

                    The file names is: Full_Domain_Name_and_URL_Path.doc

                    It's .desc is:
                    msvintradev%5Cprivate%5Cit%5Cops%5CFull_Domain_Nam e_and_URL_Path.doc.desc

                    The path where both files are uploaded to is:
                    C:\Inetpub\wwwroot\msvintradev\private\it\ops\

                    In the Zoom "offline folder for .desc files" field, I have:
                    C:\Inetpub\wwwroot\msvintradev\private\it\ops
                    The filename for your .DESC file is incorrect.

                    The filename should correspond to the URL not the path where the file is stored. You can find examples of this in the Help file page for this option (or the same thing in chapter 2.2.3 in the Users Guide)

                    For the following URL:
                    http://msvintradev:8090/departments/it/departments-it-ops-private-admin-form.cfm?id=252&intCategoryID=1&strDesc=&fileName= Full_Domain_Name_and_URL_Path.doc

                    The offline .desc filename should be:
                    msvintradev%3A8090%2Fdepartments%2Fit%2Fdepartment s-it-ops-private-admin-form.cfm%3Fid=252&intCategoryID=1&strDesc=&fileNam e=Full_Domain_Name_and_URL_Path.doc


                    [EDIT: Mind the artificial spaces added to my post by the vBulletin Forum software. The filename and URLs above should have no spaces.]
                    --Ray
                    Wrensoft Web Software
                    Sydney, Australia
                    Zoom Search Engine

                    Comment

                    Working...
                    X