Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Blank page after updating index files

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blank page after updating index files

    hello,

    today i updated the zoom index files (.zdat) cause i had some changes on my website.

    after uploading all new generated files i got blank / empty result pages: www.tandler.de. i cannot see the reason cause i changed nothing on my workflow for updating search index.

    i use Version 5.1 (1017) PRO.

    thank you for help in advance

    robert

  • #2
    Your server is returning error 500. Internal server error.

    C:\>wget http://www.tandler.de/search/search.php
    --06:27:37-- http://www.tandler.de:80/search/search.php
    => `search.php'
    Connecting to www.tandler.de:80... connected!
    HTTP request sent, awaiting response... 500 Internal Server Error
    06:27:39 ERROR 500: Internal Server Error.

    This is a very general error, so it is hard to state the exact cause.

    It might be a configuration problem on your server, it might be a corrupted PHP file. There might be additional information in your servers error log file.

    I would
    1) Try uploading all the search files again. Not just the .ZDAT files.
    2) Creating a new very small set of index files, by indexing just 1 or 2 pages and see if that worked.
    3) Try putting some other simple PHP script in this folder, just to see if any PHP script is going to run.
    4) Have a look at this old Apache / PHP issue. Where the server kills the script.

    Comment


    • #3
      Thanks for help. I reinstalled Zoom V5 and plugins and made another website scan. Uploaded all new files (but template file) and it worked again.

      Comment


      • #4
        Blank page after updating index files

        I moved a lot of my site around today in dreamweaver. I have two search folders in different locations, and they were both working fine before the changes. I did not move either search folder.

        After the changes, I rezoomed the site. I uploaded the new zoom files and I got a "file not found" error on the search page. On both of them. This is the site: http://sarcomahelp.org

        I thought perhaps there was a problem with my old template, so I deleted it and let zoom create a new one. Still no search page.

        Then I upgraded to the new zoom. I figure why reinstall if I can upgrade? So, I got the new zoom setup, the spider worked just fine. I uploaded new search files - and they don't work on either.

        Is there any chance that this is an issue on the server side? Could moving a few hundred files around cause the server to reset my php or apache settings somehow??? I don't know much about the back end, but I did check the control panel and it says php is on. I've opened a ticket with the host, but if anyone has any other ideas, I am desperate. I'm a volunteer for this charity, and here I am up at 4am trying to get search to work!

        Thanks so much,
        Mary

        Comment


        • #5
          It's most likely that when you moved your files around, you created a bunch of broken links that are now pointing to URLs that no longer exist. Most sites use relative linking, and moving files from one folder to another can be an easy way of breaking the links on your site unintentionally.

          Having said that, I just briefly looked at your site, and the site search functions seems to be working and linked fine. Did you correct this since your post? If not, can you direct us to the page and give us an example as to how you are seeing the "file not found" error.

          This is the search page we are looking at (which seems to be working fine the last time we looked):
          http://sarcomahelp.org/search/search.php
          --Ray
          Wrensoft Web Software
          Sydney, Australia
          Zoom Search Engine

          Comment

          Working...
          X