Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

OLD Version 5 GCI ERROR #502

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OLD Version 5 GCI ERROR #502

    hello,
    im running a 64 bit windows 2008 server with hosting controller installed and the apps. run with CGI IIS, Im getting this ERROR:



    HTTP Error 502.2 - Bad Gateway

    The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are "Unrecognized character \x90 at c:\webstore\admin\globalvisioncom\globalvisioncomm unication.com\www\search.cgi line 1. ".


    Detailed Error Information



    Module

    CgiModule



    Notification

    ExecuteRequestHandler



    Handler

    CGI Script Map



    Error Code

    0x00000009





    Requested URL

    http://www.globalvisioncommunication.com:80/search.cgi?zoom_query=bbb&zoom_per_page=10&zoom_an d=1&zoom_sort=0



    Physical Path

    c:\webstore\admin\globalvisioncom\globalvisioncomm unication.com\www\search.cgi



    Logon Method

    Anonymous



    Logon User

    Anonymous




    Most likely causes:•The CGI process was shut down or terminated unexpectedly before it finished processing the request.
    •The CGI process has a flaw and does not return a complete set of HTTP headers.


    Things you can try:•Check the event logs on the system to see whether the CGI process is shutting down unexpectedly.
    •Troubleshoot the CGI application to determine why it is not sending a complete set of HTTP headers.

    Could someone help me out with this issue ?????
    Thanks

  • #2
    There are several versions of the CGI (Linux, Windows, BSD, Sun). Check you are using the Windows option.

    Also check IIS isn't configured to assume all CGIs are Perl script. As this can cause the error you have seen.

    Also see this FAQ about common CGI problems,
    http://www.wrensoft.com/zoom/support/faq_cgi.html

    Comment


    • #3
      502 ERROR on Server 2008 - invalid response

      I checked the CGI and ISAPI filters and all is OK, PHP - 5.9.2 installed
      PERL and all webserver extensions are allowed ??????

      I took off the firewall and still get the same error ????
      I changed the search.cgi to an exe and it does not work ??????
      this one has got me ??????

      thanks for your prior advice,,,,,
      I going to upgrade to latest version but I have to resolve this issue ???
      http://www.globalvisioncommunication.com/


      502 - Web server received an invalid response while acting as a gateway or proxy server.
      There is a problem with the page you are looking for, and it cannot be displayed. When the Web server (while acting as a gateway or proxy) contacted the upstream content server, it received an invalid response from the content server.

      Comment


      • #4
        PHP - 5.9.2 installed PERL and all webserver extensions are allowed
        As mentioned in my last post. Having Perl setup to handle CGIs is a potential problem. If you have installed Perl then it is more likely this is the problem.

        If you try V6 and there is still a problem, and you want to give us remote desktop access to the server, then I am sure we can sort it out.

        Comment


        • #5
          thank you

          I Shal

          Thanks

          Comment

          Working...
          X