Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Indexing does not work anymore

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Indexing does not work anymore

    Hi there,

    I am not sure if this has to do with our recent switch to SSL but whenever we try to index the site (infomed.ch) we now get a message reading:
    "Could not download file: https://www.infomed.ch/index.php (Invalid URL or domain name)"

    The search results on the website just show gibberish as well.

    What can we do to fix this?

    Best
    ph

  • #2
    As a follow up: we removed the https and went back to http and the indexing worked normally again.
    Can you please let us know what and how we need to reconfigure the indexer so that it works with https?

    Thanks
    ph

    Comment


    • #3
      It should just work.
      Might be by a firewall issue?
      Can you bring up the site in Internet Explorer from the same machine on which the indexer is running?

      Comment


      • #4
        Hi again,

        So we've narrowed the problem down to the htaccess file. As soon as we add a redirect in htaccess to send all traffic to https, the zoom search does not work anymore on the website and indexing is no longer possible from the windows machine.

        Is there something specific in htaccess that could make the search engine fail?

        Thanks
        ph

        Comment


        • #5
          When you index is you start point the HTTP address or the HTTPS address?
          If you hit the redirect, then I assume you are starting at the HTTP address. Try replacing the start point with the HTTPS address.

          Comment


          • #6
            Hi again,

            Thanks for replying.
            When the redirect is on nothing works ...
            >> I tried indexing from http
            >> indexing from https
            Both fail.

            Also, the search page on the website doesn't work.
            But without the redirect the search works, even on https.

            Best
            ph

            Comment


            • #7
              We've verified that there's no problems indexing from a https:// URL with the latest build (V7.1 build 1012).

              I've also just tried indexing from your actual site, with either of the following as Start URLs
              https://www.infomed.ch/index.php
              http://www.infomed.ch/index.php

              Both indexed fine. I didn't see any redirect in either cases.

              So if you are still experiencing a problem, please check the firewall for your indexing computer.
              --Ray
              Wrensoft Web Software
              Sydney, Australia
              Zoom Search Engine

              Comment


              • #8
                Just noticed you're actually using V6.0 build 1019. That is a very old release (8 years) and no longer supported. If there was a known bug in V6 it may have been fixed in the final V6.0 release available from here. It is also very possible Windows has changed since then and it doesn't support it.

                We would advise updating to the latest version.

                Upgrade details are here.
                --Ray
                Wrensoft Web Software
                Sydney, Australia
                Zoom Search Engine

                Comment


                • #9
                  Hi again,

                  Thanks for your help.
                  The search currently works bc we removed the redirect in htaccess.
                  Here you will find a screen shot w/ the SSL redirection in htaccess enabled: https://dl.dropboxusercontent.com/u/...ss_problem.pdf

                  But understood about the release version.
                  I don't mind doing the upgrade but I want to make sure that this will fix the problem. Do you have any record about this being an issue in the past and it being fixed in newer releases?

                  Best
                  ph

                  Comment


                  • #10
                    For clarity, there's several different problems reported here. I'll try to summarize everything more clearly below.

                    Problem 1:
                    You are failing to index the website from a https:// URL. Zoom reports a "Could not download file... (Invalid URL or domain name)" error on the start https:// URL. You determined that this only happens when you have redirect enabled for all http:// URLs to https:// URLs.

                    Answer 1:
                    • You are using a very old build V6.0 build 1019 that is 8 years old. There is no recorded problem with HTTPS or redirects with this build or subsequent V6 releases, but there is at least 3 years worth of bug fixes for V6 that you are behind.
                    • V7 utilizes a completely new HTTP and HTTPS engine. So it would behave completely differently to V6.
                    • We have tested both the http:// URL and the https:// URL to work fine with the latest build at moment of writing (V7.1 build 1012) on your website. I tested it again just now and it appears that while the site is redirecting in the browser, Zoom still proceeds to index from either URLs fine and without issue.
                    • V6 is no longer supported, and we can not test the various old builds to verify what was or wasn't a problem in old discontinued releases.
                    • We also suspect it is likely a firewall issue, which you should investigate (e.g. temporarily disabling the firewall settings, or attempting to index from another computer)

                    Problem 2:
                    Your search results render as gibberish when redirect to SSL is enabled. [Shown in screenshot attached to your most recent post.]

                    Answer 2:
                    • We can see in the screenshot that, first of all, you have a PHP page (infomed_search.php). I presume this is executing a CGI, capturing the output and displaying it on the page (presumably like the wrappers described in our support page here. Let us know which method is being used, and if otherwise).
                    • There is quite possibly complications with redirections to SSL and whether PHP is set up to execute a CGI when running under SSL.
                    • The "gibberish" actually looks like a binary dump of the 'search.cgi' file. This means it is failing to execute the CGI and your PHP code is causing it to simply dump the contents of the CGI file.
                    • Interestingly, going to www.infomed.ch/cgi-bin/search.cgi causes the CGI file to download (with either http or https). This means it isn't setup to be executed properly. However, I can't confirm if this is the actual CGI file you are calling from infomed_search.php, or a stray copy from a previous setup attempt.
                    Given the above, it is possible the first problem is either Firewall related, or can be fixed by switching to V7. We cannot guarantee this without being able to confirm if the problem is your firewall or PC.

                    The second problem is very unlikely to be fixed by upgrading to V7. It is almost definitely a web server configuration issue.

                    Having said all that, as we no longer support V6, I can't continue to investigate this issue unless it is a problem with V7. So I hope the above summary of where we're at has cleared up the case and will help you get to the bottom of it.
                    --Ray
                    Wrensoft Web Software
                    Sydney, Australia
                    Zoom Search Engine

                    Comment


                    • #11
                      Thank you Ray for your detailed response.

                      >> Currently there is no redirect in the htaccess file, but SSL is on.
                      >> Yes, we are using CGI
                      >> I wasn't aware that we needed to re-assign permissions w/ the SSL certificate in place. Will look into that.
                      >> We have not changed anything on our firewall but will check if that is an issue once we do the upgrade of the indexer

                      >> I will go through all the steps and upgrades and report back.

                      Thanks for your helo!
                      ph

                      Comment


                      • #12
                        Question ...

                        I've installed v7 of the indexer on my PC but and tried to copy over the configuration for infomed.ch, however, when I try to start indexing I get a message reading "The procedure entry point GetTickCount64 could not be located in the dynamic link library KERNEL32.dll". And no indexing happens.

                        Is this due to the fact that I have the indexer installed on a Windows XP machine?

                        Best
                        ph

                        Comment


                        • #13
                          The procedure entry point GetTickCount64 could not be located
                          Yes, this an XP issue. This function was only implemented in Vista and above.
                          In Version 7.0.1024 (7 Oct 2015) we dropped support for Windows XP.

                          Comment


                          • #14
                            Hi again,

                            Here are some results w/ the new versions of Zoom:

                            1) Installed v7 on a newer windows machine. No problems installing. Manually copied the configuration for infomed.ch over to the new install.

                            2) Indexed the complete site from http:// w/ no redirect in htaccess >> all good
                            3) Uploaded files manually via ftp (trying not to break our search pages)
                            4) Did a search from the search window in the header of our pages >> all good, search results show up

                            5) However, when trying to do a search from our actual search page (www.infomed.ch/infomed_search.php) >> the search fails, i.e. it's a file not found msg bc the link is wrong (you can test this now on the live site)
                            6) The same thing happens when I try to order the search results by date or when I try to call up a sub-category of search results

                            7) When I add the redirect to SSL in htaccess >> the search fails like before


                            I tried the same thing starting the index from https. The results were basically the same as above:
                            Searching from our header search window works, but doesn't work from the search page. Adding redirect in htaccess makes the search crash.

                            I also tested starting the indexing w/ the htaccess redirect on and that now seems to work. Ie. I did not index the entire site bc I didn't want to leave the redirect on for so long but the indexing seems to work, it does not crash like it did previously in v6.

                            So I have a couple of questions:

                            >> Why does the search work from the search window in the header but not from the search page?
                            >> How do I fix the links and the search interface in our search page so that the we don't end up on an empty page. Is this something we need to adjust on our search page?

                            >> What is to be done about the problems w/ the redirect in htaccess, does this have to do with a setting that changed when SSL was added?
                            >> Is there something I need to ask our hosting company to do?

                            Thanks
                            ph

                            Comment


                            • #15
                              Originally posted by phil@infomed.org View Post
                              5) However, when trying to do a search from our actual search page (www.infomed.ch/infomed_search.php) >> the search fails, i.e. it's a file not found msg bc the link is wrong (you can test this now on the live site)
                              6) The same thing happens when I try to order the search results by date or when I try to call up a sub-category of search results
                              This looks like it's missing the "Link Back URL" setting (under "Configure"->"Advanced"). This should be set to "infomed_search.php" since you are using a wrapper page.

                              Originally posted by phil@infomed.org View Post
                              7) When I add the redirect to SSL in htaccess >> the search fails like before
                              Can you clarify if you mean it is reporting the "Could not download file... (Invalid URL or domain name)" error, or you mean the search page is failing like reported in step 5. The latter is explained above, and unrelated to the redirect.

                              Originally posted by phil@infomed.org View Post
                              I tried the same thing starting the index from https. The results were basically the same as above:
                              Searching from our header search window works, but doesn't work from the search page. Adding redirect in htaccess makes the search crash.
                              It's important to be consistent and clear with describing the problem. What are you describing as "makes the search crash"? Is it the "Could not download file..." error? Or is it the gibberish output? Or is it the "File not found" error? Technically, none of these are a "crash" (which is when an executable fails during execution and terminates prematurely). So this is ambiguous.

                              Originally posted by phil@infomed.org View Post
                              I also tested starting the indexing w/ the htaccess redirect on and that now seems to work. Ie. I did not index the entire site bc I didn't want to leave the redirect on for so long but the indexing seems to work, it does not crash like it did previously in v6.
                              OK, so this means V7 is indexing better, and you're no longer getting the "Could not download file..." error? If that's the case, we can narrow down what we're looking at.

                              Originally posted by phil@infomed.org View Post
                              >> What is to be done about the problems w/ the redirect in htaccess, does this have to do with a setting that changed when SSL was added?
                              It's not clear which problem is persisting, that is related to the redirect. Are you still getting the gibberish output?

                              --Ray
                              Wrensoft Web Software
                              Sydney, Australia
                              Zoom Search Engine

                              Comment

                              Working...
                              X