Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Result title links trouble

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Result title links trouble

    Hi!

    I am using the latest version of Zoom Search Engine Free Edition (method "PHP Platform").
    I have a problem with the listed result title in some browsers. The links of the first three titles in the list don't work (as plain text without links). Instead, the links works from the fourth title on the result list...

    This problem happens on the browsers Firefox and Google Chrome (no problem on Internet Explorer and Opera).

    I think that this is a bug, because I did not change the relevant settings.
    Are there any solutions?

    Thanks and Greetings.

  • #2
    More likely it is something special about your site that is causing the browsers to behave differently.

    What is the URL for the search function and what was the search word used?

    Comment


    • #3
      The URL is http://alvin68.altervista.org/

      But the site is still under construction, and there is no content pages.
      I'm just doing the trial run with the content of the footer page (then I will exclude it from indexing). For example, I used the search words "produzioni" or "cineforum"...

      Another change that I will It is the number for results returned per page (setting from 10 to 5), because with defaults values my box div does not contain all the strings...

      Comment


      • #4
        This is not a bug in Zoom.

        There are many invisible and overlapping layers on your template page, as part of your site design. These are causing issues with Firefox and Chrome, and they are being rendered on top of the search results (although invisible) and thus blocking the ability to click on them.

        The direct cause appears to be your JavaScript menu layers. If you modify your "main.css" file and temporarily remove the style defined for "#menubox" (and refresh the page), you will find that the top 3 search result links will be clickable.

        It's also worth noting that your side menus aren't showing up at all on the page (even before you enter a search query) which is probably another issue. When you do enter a search and the results show up, they overlap the bottom footer of the page due to hard-coded height attributes for the content box layer. This is a clear indication of layer design issues. Setting a smaller "results per page" limit will merely avoid this, but it does not fix the problem.

        For example, you can link to Zoom like this and limit the search results to 5 per page:
        http://alvin68.altervista.org/tlsearch/search.php?zoom_query=produzioni&zoom_per_page=5

        Notice that it will seem like it fits in the page. But if you change the font size in your browser to a bigger size, it will again, overlap the footer. This problem is not restricted to Zoom's search results. It will happen for all your other pages once you have text on them.

        Your current design and HTML is basically guaranteed to not work on different browsers, different browser settings, resolutions, etc. You will need to look at addressing these issues to ensure better cross browser compatibility.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Thanks for the explanation.
          In fact, I'm already trying to set the css to display crossbrowsers (I'm using the conditional comments for IE too), but I haven't set all, for example the text's line-height not again...
          My menu is not in javascript but it's a swf flash and if the trouble is the style defined for "#menubox" div... now it's really a big trouble, because it's the only method that I found to put the swf on the page (its position, etc.)

          However, I will do more testing, even for the content text in the central box div.
          I will make you know, hoping to resolve.

          Best regards.

          Comment


          • #6
            Originally posted by alvin68
            My menu is not in javascript but it's a swf flash and if the trouble is the style defined for "#menubox" div... now it's really a big trouble, because it's the only method that I found to put the swf on the page (its position, etc.)
            Well, I solved this problem, simply changing the value of z-index layer #searchresultsbox.
            Setting higher than the transparent layer of the swf, the links works.

            Now, I hope to solve the other problem: the results shown over the bottom footer of the page.

            Comment


            • #7
              You might want to consider using a simpler more maintainable layout for your site as you seem to be getting confused by your own somewhat complicated CSS tricks.

              Comment


              • #8
                Originally posted by alvin68
                Well, I solved this problem, simply changing the value of z-index layer #searchresultsbox.
                Setting higher than the transparent layer of the swf, the links works.
                I thought I had resolved, but unfortunately and obviously the problem still occurs for all the contents of my layout, and these pages' contents (text, forms, etc.) should not overlap the submenus...

                Originally posted by wrensoft
                You might want to consider using a simpler more maintainable layout for your site
                After so much work, it is difficult for me to give up this template.

                Comment


                • #9
                  Originally posted by alvin68 View Post
                  I thought I had resolved, but unfortunately and obviously the problem still occurs for all the contents of my layout, and these pages' contents (text, forms, etc.) should not overlap the submenus...
                  I believe you're talking about the other pages on your site, and not the search page right? Personally, I think the problem with your template is eventually going to come back and bite you, even if you work-around it for now...

                  As we hinted at above, your "template" is really, to be frank, quite bad HTML. At least the current incarnation of the template is anyhow (with the menus and that). The page layout is put together by many various floating layers and they are positioned around the page with a combination of absolute and relative positioning. This approach basically guarantees that the page won't look the same in different browsers, let alone on another computer, with different resolutions, etc. Everything is dependent on things appearing exactly where you see them on your computer and in your browser. Someone with a different browser, or different font sizes, will see all the layers overlapping (as you have found).

                  The actual graphical/aesthetics design is fine (it's very nice actually), it's just the underlying way it is implemented in HTML and CSS. It shouldn't be necessary given what you are trying to achieve.

                  Anyway, it is up to you how you can proceed. My job isn't to offer web design advice, so I haven't looked into what's part of your original template and what you've added. Perhaps it's just the things that you've added that's broken it from a CSS point of view.
                  --Ray
                  Wrensoft Web Software
                  Sydney, Australia
                  Zoom Search Engine

                  Comment


                  • #10
                    Originally posted by Ray
                    Anyway, it is up to you how you can proceed. My job isn't to offer web design advice, so I haven't looked into what's part of your original template and what you've added. Perhaps it's just the things that you've added that's broken it from a CSS point of view.
                    Yes, Ray, I know this, and I thank you anyway.
                    But my layout works fine on different browsers (tested with IE 5.5/6/7/8, Firefox, Opera and Google Chrome) and with different resolutions (I used fixed sizes of the div-boxes and combination of absolute and relative positioning for this reason). To preserve my graph template I decided not to use float property of the elements, choosing not to worry about users who use large or different font sizes (not default size).
                    The real problem that struck me was the layers overlapping between swf and page elements, the different interpretation between IE and Firefox compared to this thing!
                    Probably, the only solution is to build a different menu swf...

                    Best regards.

                    Comment


                    • #11
                      Originally posted by Ray
                      For example, you can link to Zoom like this and limit the search results to 5 per page:
                      http://alvin68.altervista.org/tlsearch/search.php?zoom_query=produzioni&zoom_per_page=5
                      Sorry, Ray, another question...

                      How do I set as the default value of 5 for results per page in my file search_template.html?
                      I tried with the following strings:

                      Code:
                      <form method="get" action="search.php?zoom_query&zoom_per_page=5">
                      or

                      Code:
                      <form method="get" action="search.php?zoom_per_page=5">
                      ...but doesn't work.

                      Comment


                      • #12
                        Use a hidden input tag inside the form like this:

                        Code:
                        <input type="hidden" name="zoom_per_page" value="5">
                        --Ray
                        Wrensoft Web Software
                        Sydney, Australia
                        Zoom Search Engine

                        Comment


                        • #13
                          Thanks, now it's ok.

                          Comment

                          Working...
                          X