Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Base Url - relative path issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Base Url - relative path issue

    I have Zoom Search set up to index my site in spider mode. However, it is not working when I use a relative path for the Base URL of "../"

    My site uses a lot of includes so I thought using spider mode was better then offline mode. My issue occurs when I move the files from the development server to a production server. The Base URL is something like www.my-dev-server.com, when I move to production (www.production-server.com) all of the url's are pointing at the dev server.

    I do not wish to spider the site for qa and production, I'd like one search to work on both servers. Is this possible?

  • #2
    Use the re-write links function (on the indexing options configuration window).

    From the help file,

    Rewrite links


    This option allows you to rewrite the indexed URLs of the pages indexed. This can be useful if you are spidering a development version of your site on a test server (eg. http://test.mycompany.com/) and creating index files to go on the live server (eg. http://www.mycompany.com/). You would do this by specifying rewrite options to replace all instances of "http://test.mycompany.com/" in the indexed URLs with "http://www.mycompany.com/".


    You could also use this option to change all the search result links to be relative rather than absolute by replacing the domain (eg. "http://www.mysite.com/") with a relative path (eg. "./" or "../"). We only recommend this for users who are very familiar with relative linking and understand that the linking would only work if the generated search files are placed in an appropriate folder on the server.

    Comment

    Working...
    X