Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Capital letters vs. small letters and Server problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Capital letters vs. small letters and Server problem

    Hi all,
    first of all I would like to thanks for this Sofware. It wokrs fine!!
    But I have 2 problems (quesions).
    1. I have made an Index for a CD/DVD. It works fine but if I enter a word in capital letters (like "BSE") I do not get anny results. If I enter "bse" I get all of the results.
    So what did I do wrong?

    2. We have a clinent who is using the windows server (asp works) but if I try to start the indexing I get the error "Could not download file: http://www.server1.com/... (Forbidden)

    If I try try to open the directory directly on the browser I get the mes. "Directory Listing Denied
    This Virtual Directory does not allow contents to be listed."

    Any ideas what I can do?
    Thanks a lot for your help from Hamburg!!

    Sven
    Last edited by Sven_HH; 01-10-2011, 10:43 AM.

  • #2
    Q1. By default the search is case insensitive. But there is an option to make it case sensitive in the languages configuration window. So maybe you accidentally checked the "support for single case languages" box?

    Q2. Forbidden means the server has returned a HTTP Error 403 Forbidden error code. As you get also an error when looking at the site in a browser, then there is clearly something wrong with the site. Maybe it is missing a home page (index.html page).

    Comment


    • #3
      Hi thanks for yoour answers.
      The first question is answered again thanks.

      regardin the 2. one.
      I have the same presentation on a different Server (Linux) and there it works fine. I just get the error if I try to access the dirctory if I enter the url to open a pdf it works. The Indexpage is in the root directory in the subfolders are pdf and html files.

      Comment


      • #4
        If you have the same files on 2 servers and it works on one server and not the other (from the same browser), then clearly there must be a difference in the web server software or the configuration of the web server software.

        If you can't get the site's home page displaying in a browser, then it isn't really a problem with our software. You need to fix the site.

        Start by looking at the web server configuration and the behaviour you have set for selecting a default file, when no file is selected in the URL.

        For example if you are running the Apache web server then the command to set the default file is "directoryindex". See,
        http://httpd.apache.org/docs/1.3/mod...directoryindex

        You might also want to look up automatic directory listing option settings.

        Comment


        • #5
          It's unclear what you are saying. Are you saying there is a working home page or index page in the root directory, but you are getting the forbidden message on a subfolder containing PDF and HTML files?

          Note that your original post said this:
          2. We have a clinent who is using the windows server (asp works) but if I try to start the indexing I get the error "Could not download file: http://www.server1.com/... (Forbidden)
          And it seems like you were talking about the front page.

          If in fact, you are talking about a subfolder (i.e. http://www.server1.com/subfolder1/ is the Forbidden message), then yes, the problem is most likely because of the lack of directory listing.

          Spider mode works by following links on a page. If your Linux server is configured to return directory listing (so if you go to the URL you used as your Zoom start URL in a browser, and you can see a page with a list of links), then Zoom will be able to follow these links and index the files.

          It would seem apparent that your Windows server is not configured to return directory listing, so that's why there is no way for the spider to find the files. Look up your Windows server IIS documentation on how to enable directory listing (aka directory browsing) on the necessary folders. Here is one such tutorial.
          --Ray
          Wrensoft Web Software
          Sydney, Australia
          Zoom Search Engine

          Comment


          • #6
            Hi Ray,

            thanks a lot for you help but the Server is not under our "configuration" Anyway I created the Index offline and uploaded it via ftp. It works fine but the search takes verry very long. Any Idea how I can speed it up?

            Thanks
            Sven

            Comment


            • #7
              I think you posted the same question in a new thread here. So I won't repeat the answer here.

              Comment

              Working...
              X