Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Trouble with Category Indexing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with Category Indexing

    I need my website indexed by category. The French, Portuguese and Spanish sections are all in separate folders so I entered a match pattern of /es/ for Espaņol, /fr/ for French and /pt/ for Portuguese. My question is, how do I configure the English indexing? Whatever I did is not working. Right now, I'm not getting any search results in Fr, Es or Pt, and the English option is retrieving files in other languages! All English files are in the root directory and some of them are in folders. For example, index.htm , testimonials.htm , /low_vision/, /tty/, etc. Any help is greatly appreciated.

  • #2
    Can you give us a link to the website and some actual URLs for reference? Sometimes it's in the details. For example, URLs are case sensitive, so if your URLs are like this: http://www.mysite.com/ES/index.html then it will not match a category for "/es/" because it is in uppercase.

    We'll also need to see exactly how you specified the categories in your Zoom configuration. You can email us the .zcfg configuration file if need be.

    With specifying the English category, you can omit it in the categories list and use the option "Catch files not belonging to a category in: " and specify "English" there. This means all files not belonging to one of the defined categories above it, will now belong to the English group.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Thank you. I followed your advice. It partially solved the problem. Now, I can search in Spanish, French and Portuguese, but not in English. The drop-down menu does not give me an English option. How can I get around this? My search page is located at http://www.assistech.com/search/search.php I emailed you my config file.
      Last edited by Ollie; 01-10-2011, 11:18 PM.

      Comment


      • #4
        I've just responded to your e-mail. I've copy and pasted my response below for anyone else following this thread:

        We had a look at your config file and reproduced the problem. It appears to be a bug in the current release. But fortunately, there is a workaround.

        Uncheck the option "Catch files not belonging to a category in..."

        Add a new category and name it "English" with a match pattern of "*". Make sure to leave this as the last category in the list.

        This will effectively do the same thing and catch all the files not belonging to the other categories under "English". It should show up in the dropdown and allow you to search for it.

        We will fix the problem with the first situation in the next release (V6.0 build 1026).
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment

        Working...
        X