Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Something went wrong with my search engine!!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Something went wrong with my search engine!!!!

    The following is my search bar code:
    Code:
     <center><p><img src="logo.jpg" border="0" alt="" />
    <form method="get" action="/search/search.cgi/"> 
    <table cellpadding=0 cellspacing=0> 
    <tr valign=top><td width=25%>&nbsp;</td> 
    <input type=hidden name=bih> 
    <div class=ds style="height:32px;margin:4px 0"> 
    <input type="text" name="zoom_query" input autocomplete="off" maxlength=2048 class="lst" 
    title="Hinsmart Search" value="" size=70 style="background:#fff;border:1px solid #ccc;
    border-bottom-color:#999;border-right-color:#999;color:#000;font:18px arial,sans-serif bold;
    height:25px;margin:0;padding:5px 8px 0 6px;vertical-align:top"></div> 
    <style="line-height:0">
    <input type="submit" value="Hinsmart! Search" class="zoom_button" />
    But when guests try to search, they got internal server error. My search file is search.cgi.
    Kind regards,
    Tsui Jenkin
    President of Hinsmart (hinsmart.com)

  • #2
    An internal server error means there was an error on your server (unsurprisingly).

    Was it working in the past?
    What changed on the server at the time it stopped working?

    Unfortunately this is a very general error and can be caused by dozens of problems.

    You should check the server's error log file to see if there is additional details. There often are.

    It is highly unlikely that the problem has anything to do with the code you posted for the search box.

    Also see this FAQ for the CGI option.
    http://www.wrensoft.com/zoom/support...gi_servererror

    Comment


    • #3
      re:

      The internal server error has occured sinced I changed encoding and character sets from English / latin 1 to utf-8 encoding.
      Kind regards,
      Tsui Jenkin
      President of Hinsmart (hinsmart.com)

      Comment


      • #4
        Were there any errors in the web server log from when a search was attempted?

        Did you make sure your index files are all up to date on the server?

        Did you check the points in the FAQ above.

        Comment


        • #5
          Re:::

          I uploaded all the files on there.
          I tried put my files into the cgi-bin.

          When i opened the search.cgi file, it said this program cannot run in DOS mode.

          ?????
          Kind regards,
          Tsui Jenkin
          President of Hinsmart (hinsmart.com)

          Comment


          • #6
            You problem is surely covered in the FAQ should you wish to read it,
            http://www.wrensoft.com/zoom/support/faq_cgi.html

            Maybe you are using the wrong CGI, but you haven't provided enough details to really know. Again see the FAQ to start with.

            If the CGI is too hard to install, then consider using the PHP option, which has less pre-requisites.

            Comment

            Working...
            X