Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Duplicate results - this might help someone

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Duplicate results - this might help someone

    I'm new to Zoom and have been tweaking the configuration of my indexing for a couple days. Despite having checked the CRC box to turn on duplicate page detection, I was still seeing duplicates:

    www.mydomain.com/
    www.mydomain.com/default.aspx

    When I did View Source on these pages, I noticed that the action for the form was different - the one for the / URL was Default.aspx

    Sure enough, in IIS, the default document was listed as Default.aspx, not default.aspx

    I changed that for all the affected sites, and now I have no more duplicates.

    Maybe this will help someone at some point.

  • #2
    You can also wrap parts of the HTML with the <!--ZOOMSTOP--> and <!--ZOOMRESTART--> tags to exclude it from both being indexed and from being included in the CRC duplication check. So if you enclose the HTML that is changing, it will allow the page to be identified as a duplicate.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Originally posted by Ray View Post
      You can also wrap parts of the HTML with the <!--ZOOMSTOP--> and <!--ZOOMRESTART--> tags to exclude it from both being indexed and from being included in the CRC duplication check. So if you enclose the HTML that is changing, it will allow the page to be identified as a duplicate.
      So are you saying that I could have something like this?

      <...some code...>
      <!--ZOOMSTOP-->
      <form runat="server" action="myPage.aspx" id="myForm">
      <!--ZOOMRESTART-->
      <... the page content...>
      </form>
      <.... some more code...>

      So the ZOOM tags don't have to act like normal tags, which shouldn't be overlapped like that?

      Even though I could make this change an a single master page, I think I prefer my approach of preventing the difference from happening in the first place.

      But thanks for the suggestion.

      Comment


      • #4
        I believe that should work, but I haven't tested it myself. It's up to you of course, but if you do end up trying that, let us know (make sure to turn off caching with "Configure"->"Spider options"->"Reload all files (do not use cache)" if you make this change and immediately spider afterwards).

        But yes, absolutely, if you can prevent the difference from happening in the first place, then that would be preferrable.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment

        Working...
        X