Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Schedule Automatic Indexing on Windows 8

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Schedule Automatic Indexing on Windows 8

    Hello,

    I have Zoom Search Engine version 6.0 build 1028. I set up automatic scheduling to index four of our websites during night time. It was working fine in Windows 7 Enterprise.

    Now I did clean install of Windows 8 Enterprise (for testing purposes for now because we don't have college-wide VL key yet), installed Zoom Search Engine. It is working fine using ASP.NET. But when I click "Schedule automatic indexing" from the Tools menu I get this pop-up message:

    "The current user account does not have permission to access the Windows scheduling service. Check your access rights for the current user account. You may need to be a Power or Administrator User to start the scheduler."

    My domain ID is the member of the local Administrators group. I googled that message and cannot find any resolution.

    Did you guys (Zoom programmers) test Zoom on Windows 8?

    Thanks.

  • #2
    When launching Zoom, can you try right clicking on the icon and select, Run as admin.

    Comment


    • #3
      I tried that and it worked.

      But the issue is that I need to log in to my computers with domain ID to get network resources. I am also mapped automatically to my “Home” drive by login script. All Zoom’s configuration files, language files, and zdat files are located on my “home” drive so I can easily upload zdat files to the web servers from any computer in domain.

      When I run Zoom as administrator my “Home” drive is unavailable and I cannot load configurations for indexing websites. Of course I can copy all those file to my PC where Zoom installed, but that is very inconvenient.

      <rant>Thanks Microsoft for making life easier with Windows 8</rant>

      Comment


      • #4
        You should only need to run as elevated administrator to schedule the indexing task. Make sure to create the schedule task for the normal user account you use (you specify the login name and password when creating the task).

        EDIT: OK, I just realized you can't load the .zcfg file you want to use in that case. I guess it's convoluted but what you can do is, schedule a task with any other .zcfg file that you CAN access. Then go to Windows Scheduled Tasks (can't remember off the top of my head where it is in Windows 8, but it used to be under "Administrative Tools"), locate the Zoom task, right click and Properties, and change the command-line parameter so that it points to your network accessible .zcfg file instead of the one you scheduled it with.

        Should work, let us know if not.

        And yeah, we've been finding a whole world of spaghetti-loose-wiring in Windows 8, that will likely prove to be frustrating in the next year or so as adoption increases. It is certainly a long way from a cohesive or consistent experience.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Originally posted by Ray View Post
          And yeah, we've been finding a whole world of spaghetti-loose-wiring in Windows 8, that will likely prove to be frustrating in the next year or so as adoption increases.
          Thanks for the laugh Ray.

          I will try work around tomorrow. For tonight I moved all files to my local PC to run four indexing processes as local administrator.

          Comment


          • #6
            Speaking personally, so far, my experiences with Windows 8 have been akin to driving a new car where some genius decided that the big selling feature is that it has no steering wheel. "That's brilliant!", I'd say, "... how would you turn around corners then??"; "Oh, well when you come upon a corner, then you have to use the steering wheel which has been shrunken into minature form and fit inside the glove box on the passenger side"; "Hmmm..."
            --Ray
            Wrensoft Web Software
            Sydney, Australia
            Zoom Search Engine

            Comment


            • #7
              Ray,

              I change setting for two out of four Zoom tasks this morning and was able to run those two tasks manually. I left other two as they were last night. I will see how all four tasks run this night automatically.

              Comment


              • #8
                Update.

                Zoom application was set to run normally under my network ID and not as local administrator. Two indexers in the Windows 8 Scheduler were set to use ZCFG files from and save ZDAT files to the local hard drive, and two indexers were set to use network drive for ZCFG and ZDAT files.

                Task Scheduler shows that all four tasks (indexers) ran last night. Three of the tasks show "The operation completed successfully" under "Last Run Result" column. One tasks shows "Incorrect function. (0x800700001)" under "Last Run Result" column, but I uploaded ZDAT files to the web server and Zoom Search working fine in the browser.

                Comment


                • #9
                  If you wish to investigate the error status, you can enable logging for that ZCFG file ("Configure"->"Index log"->"Save index log to file" and also enable "Append date and time to log filename"). Then for each index session, a log file will be saved to disk. Make sure to also enable Logging mode to "Detailed" if you need more information.

                  This should let you confirm what happened on that occasion when the task reports "Incorrect function" and whether the indexer completed successfully entirely or what might be the issue.
                  --Ray
                  Wrensoft Web Software
                  Sydney, Australia
                  Zoom Search Engine

                  Comment


                  • #10
                    Ray,

                    I have detailed logging enabled. I just ran indexer manually from Task Scheduler and got log file. But I am not sure what to look for in the log file. Can you take a look, please. I sent you PM with the link to ZIP file.


                    Regards
                    Last edited by Mozartman; 11-09-2012, 03:46 PM.

                    Comment


                    • #11
                      Was this log file from a scheduled session where the Task Scheduler showed the status of "Incorrect function"?

                      I don't see any problem in this log file. Nothing that would indicate the indexer did not complete successfully.
                      I don't think it would have terminated prematurely or returned any unusual status to the Task Scheduler.

                      Double check that this log file came from a session with the above status. And it is not one of those that just completed with "The operation completed successfully". Otherwise the cause of the status might be something else besides what Zoom is returning.

                      Looking online, I've seen causes of the error related to backup processes and in one case, due to running the 32-bit executable instead of the 64-bit version. Generally we are not aware of any issue with running the 32-bit indexer on a 64-bit OS, but it might be another thing to try.
                      --Ray
                      Wrensoft Web Software
                      Sydney, Australia
                      Zoom Search Engine

                      Comment


                      • #12
                        Ray,

                        That log was from manual run. I was monitoring logs for three days and all four indexers ran each night. All four logs have last line saying:

                        03|11/14/12 03:13:59|Successfully created all required files

                        I will leave that "incorrect function" alone for now. Thanks for your help.

                        Comment

                        Working...
                        X