Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Apostrophe crashes search, then throws 403 Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Apostrophe crashes search, then throws 403 Error

    I have a test configuration of Zoom running on Wordpress and it works very well. Recently I tried to search for the word West's. Instead of getting a search result there is a long list of links where the search results used to show up. The links point to the wordpress admin panel functions and the default wordpress search form is also there, although I thought I had removed completely from the site. The zoom search form is still there, but trying another search from it throws a 403 error, as does clicking on any link on the search page (including the ones to the admin area).

    Apparently the problem is the ' character, which causes the crash. When logged out from the Wordpress admin, the same search just produces a blank result, i e nothing shows below the search form, but then when I try to click on a link to another page on the site it throws a 403 error. A clueless visitor will just see the blank area beneath the search form if he tries to search for a word containing the ' sign, then he will be left in the dark and blocked from the site by repeating 403 errors.

    In IE the style of the search page crashes completely. In Firefox style is normal, but both browsers then display the same 403 error.
    Last edited by kazbek; 11-09-2012, 12:34 AM. Reason: grammar

  • #2
    I just had a look in the Wordpress forums and this could be due to wordpress escaping single quote marks (=apostrophe?) in url's and breaking or even the .htaccess rules. The ' character is in the url after the search, so clearly that's where the problem is. Is there a way around this in Zoom perhaps? Stripping the ' character in searches?

    Comment


    • #3
      Sounds like Wordpress is doing something quirky. We're not Wordpress experts here, but if you give us a link to your site, we can at least investigate it directly. PM or e-mail us the link if you wish to remain private.

      If you need to strip the apostrophe sign from ever appearing in the URL after it's been entered into the form, then that's outside of Zoom's reach. That all happens within your browser. What you type into the HTML form is taken by the browser and the URL is formed by the browser and submitted to the web server (where the Zoom PHP script resides).

      You would most likely need to use JavaScript code (which runs on the server) to intercept the form input and change it before the page submits.

      The closest thing Zoom has control of is the "Indexing Options"->"Word join rules" which allow you to disable apostrophes from joining a word. When this is configured (re-indexing required), a search for the word "West's" would be converted to "West s" and treated as two words and the apostrophe removed. However, by the time this happen, it's already been submitted and become part of the URL.
      --Ray
      Wrensoft Web Software
      Sydney, Australia
      Zoom Search Engine

      Comment

      Working...
      X