Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

PPT Index Failure

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PPT Index Failure

    I read about the problem indexing ppt extension files created with PowerPoint 2010. I cannot use the pptx
    format for these files as Microsoft's Internet Explorer saves these types of files with a zip extension
    when they are downloaded. I also do not have access to an earlier verison of PowerPoint. Is there
    some other way around this problem that will allow them top be indexed?

  • #2
    PPTX files are in fact Zip files (a compressed collection of OpenXML files to be exact). But this shouldn't happen.

    Is this your server?
    If you set the HTTP Mime type correctly on your server then PPTX files (and XLSX & DOCX) should be saved correctly.

    This is what you need for PPTX

    .pptx application/vnd.openxmlformats-officedocument.presentationml.presentation

    You can find a complete list here,
    http://technet.microsoft.com/en-us/l...ffice.12).aspx

    Comment


    • #3
      The site is hosted with Network Solutions. They insist that the MIME types are set correctly.
      As far as I can tell there is no way for me to alter them.

      Comment


      • #4
        You can modify them via the Apache .htaccess file if you are using Apache.

        It is trivial to check the MIME type, if you have a URL to a PPTX file on your server?

        Comment


        • #5
          I see a file named .htaccess in the top level directory I have access to. It contains the following:

          AddType application/vnd.ms-word.document.macroEnabled.12 .docm
          AddType application/vnd.openxmlformats-officedocument.wordprocessingml.document docx
          AddType application/vnd.openxmlformats-officedocument.wordprocessingml.template dotx
          AddType application/vnd.ms-powerpoint.template.macroEnabled.12 potm
          AddType application/vnd.openxmlformats-officedocument.presentationml.template potx
          AddType application/vnd.ms-powerpoint.addin.macroEnabled.12 ppam
          AddType application/vnd.ms-powerpoint.slideshow.macroEnabled.12 ppsm
          AddType application/vnd.openxmlformats-officedocument.presentationml.slideshow ppsx
          AddType application/vnd.ms-powerpoint.presentation.macroEnabled.12 pptm
          AddType application/vnd.openxmlformats-officedocument.presentationml.presentation pptx
          AddType application/vnd.ms-excel.addin.macroEnabled.12 xlam
          AddType application/vnd.ms-excel.sheet.binary.macroEnabled.12 xlsb
          AddType application/vnd.ms-excel.sheet.macroEnabled.12 xlsm
          AddType application/vnd.openxmlformats-officedocument.spreadsheetml.sheet xlsx
          AddType application/vnd.ms-excel.template.macroEnabled.12 xltm
          AddType application/vnd.openxmlformats-officedocument.spreadsheetml.template xltx

          Comment


          • #6
            So it should be OK in theory.
            If it isn't then maybe you have a second deeper level .htaccess file that is changing the settings. Or maybe you aren't using Apache at all, in which case this file would be ignored.

            Comment


            • #7
              The server at Network Solutions shows to be a Windows box. If the site was on an Apache box would a .htaccess
              file like this placed in one of the directories I have access to correct this problem?

              Is there a program that will convert pptx files to a ppt format that your search engine will read, other than
              an older version of PowerPoint?

              Comment


              • #8
                Window's boxes normally run IIS as their web server software, not Apache.
                Linux and Unix boxes typically run Apache.

                So if you are running IIS then the .htaccess file will be completely ignored. There is a different procedure to edit mime types on IIS.
                http://technet.microsoft.com/en-us/l...(v=ws.10).aspx

                Again, it is trivial to check if the MIME type is set correctly yourself. If you can tell us just a single URL to a PPTX file on your server?

                Powerpoint will save presentations into a bunch of other formats. Including HTML & PDF.


                Comment


                • #9
                  Well I just changed them all to ppt from pptx to avoid the download problem.
                  I have changed these two back to pptx so you can see what I am talking about.

                  http://www.chipps.com/10/Wired%20Med...tiplexing.pptx
                  http://www.chipps.com/10/Wireless%20...tiplexing.pptx

                  I understand from the articles you posted the links to as to how to correct his problem,
                  but I do not have that level of access to the web server settings through Network Solutions.

                  Comment


                  • #10
                    After indexing it looks like the doc and xls files do index correctly saved into those formats using Office 2010.
                    Is this just a ppt problem when saved as a ppt file from Office 2010?

                    Comment


                    • #11
                      So here is a copy of the HTTP headers that have been returned from your server back to browsers,
                      HTTP/1.1 200 OK
                      Connection: close
                      Date: Tue, 13 Nov 2012 21:28:28 GMT
                      Content-Length: 934690
                      Content-Type: application/octet-stream
                      Last-Modified: Tue, 13 Nov 2012 19:28:41 GMT
                      Accept-Ranges: bytes
                      ETag: "6c619b16d5c1cd1:6b9"
                      Server: Microsoft-IIS/6.0
                      X-Powered-By: ASP.NET

                      The following points are of interest.
                      1) You are in fact running IIS 6.0
                      2) The content type field is wrong.

                      Now if I upload your file to our server, then look at the HTTP headers I get this from our server.
                      HTTP/1.1 200 OK
                      Date: Tue, 13 Nov 2012 21:34:00 GMT
                      Server: Apache/2.2.23
                      Last-Modified: Tue, 13 Nov 2012 21:33:46 GMT
                      ETag: "e4322-4ce672c3d2280"
                      Accept-Ranges: bytes
                      Content-Length: 934690
                      Connection: close
                      Content-Type: application/vnd.openxmlformats-officedocument.presentationml.presentation

                      See how the Content-Type is different on a correctly setup server.

                      So you should go back to your hosting company and tell them the MIME type is set wrong, using the above as proof.

                      Further, I tested the original premise. That IE saves PPTX files as ZIP files when the content type is wrong. This turns out to be mostly false. In IE9 & 10 the file is saved correctly. So maybe you don't really have the issue you thought you had. Maybe it might have been true back in IE6, but I don't have really old browsers to test with.

                      Comment


                      • #12
                        In answer to the 2nd question, yes the problem is only with PPT files saved with new versions of Office. See this FAQ for details.
                        http://www.wrensoft.com/zoom/support...s.html#ppt2007

                        Comment


                        • #13
                          I use IE8. This is true for IE8 and earlier.

                          It looks like a change of hosting companies is the only answer.

                          Comment


                          • #14
                            There are a number of solutions, you just need to pick the one you want to use.

                            The obvious solution in my opinion is to get the server configuration fixed. There is irrefutable evidence that it is wrong at the moment.

                            I would also note that everyone is starting to drop support for older versions of IE.

                            This is what Google is saying about Google Apps and IE8 for example,

                            Internet Explorer 8 users

                            As previously announced, Internet Explorer 10 launches on October 26, 2012, and as a result, we will discontinue support for Internet Explorer 8 shortly afterwards, on November 15. Prior to this date, users accessing Google Apps services using Internet Explorer 8 will see a message recommending that they upgrade their browser.

                            Comment

                            Working...
                            X