Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Categories dropdown

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Categories dropdown

    I seem to be doing something basically wrong with my categories configuration.
    I have defined the categories and have played with different configurations of the boxes below
    (allow searching...show category...) and I cannot seem to get a dropdown to come up.
    I have re-indexed and re-uploaded each time I change the category settings..... I can see that it is
    searching the different sites I have configured.
    I have dug through the documentation and forum..... I must have a basic problem I am not seeing.

    Right now, the site is being developed so it has a weird url.
    http://www.cgaconference.com/damagepreventionprofessional.com

    the search doesn't appear to be going to the other category sites, either??


    Thanks for your help.
    stephaniem

  • #2
    Originally posted by stephaniemull View Post
    I seem to be doing something basically wrong with my categories configuration.
    I have defined the categories and have played with different configurations of the boxes below
    (allow searching...show category...) and I cannot seem to get a dropdown to come up.
    I have re-indexed and re-uploaded each time I change the category settings..... I can see that it is
    searching the different sites I have configured.
    I have dug through the documentation and forum..... I must have a basic problem I am not seeing.

    Right now, the site is being developed so it has a weird url.
    http://www.cgaconference.com/damagepreventionprofessional.com

    the search doesn't appear to be going to the other category sites, either??


    Thanks for your help.
    stephaniem
    OOPS -- please strike that part thta says "i can see that it is searching through the different sites I have configured.
    I went back and checked and then added the final statement - which is true - that it does NOT appear to be
    going to all the different urls.

    Comment


    • #3
      I had a look at your site.
      You seem to be using a script called "search_results.php". This is not our script.

      So to start with can you revert to using our original search.php script and see how that works.

      You also need to rebuild your index when you change the categories configuration.

      Comment


      • #4
        Originally posted by wrensoft View Post
        I had a look at your site.
        You seem to be using a script called "search_results.php". This is not our script.

        So to start with can you revert to using our original search.php script and see how that works.

        You also need to rebuild your index when you change the categories configuration.

        but, my search results is just a formatted page that calls your search in a different directory:
        <? include('search/search.php'); ?>
        I know I need to rebuild the index every time - I have been doing that.

        ???

        Comment


        • #5
          Looking at the output from the search script, it seems to me that none the documents are actually in any category.

          So maybe you have defined a number of categories and corresponding patterns for each category, but none of the documents match any of the patterns you have defined. Meaning all the categories might be empty sets.

          Comment


          • #6
            oh, ok.
            I thought I could just put the url of the directories/websites I wanted to do:
            such as http://www.damagepreventionprofessional.com/*.*
            That doesn't work?
            does the categoryt thing only work if you have the documents defined as categories - I did read the manual, but
            maybe didn't understand that part.
            I just want my categories to be WHERE the search looks......

            Comment


            • #7
              I think you actually pointed out the problem in an earlier post...

              Right now, the site is being developed so it has a weird url.
              http://www.cgaconference.com/damagepreventionprofessional.com
              So a pattern like,
              http://www.damagepreventionprofessional.com/*.*
              is never going match anything, given the current URLs in use.

              Comment


              • #8
                yeah, but....... there is a REAL site at damagepreventionprofessional.com - it is the current site.
                And, my other sites (categories) exist, too.
                http://www.cgaconference.com/*.*
                http://www.excavationsafetyguide.com/*.*
                http://www.excavationsafetyuniversity.com/*.*
                http://www.damagepreventionprofessional.com/news/*.*

                Is this how I am supposed to define them, like above in the categories pattern???

                The client has several related sites and I want the search to be able to look at one or all of them.....?

                thank you.

                Comment


                • #9
                  The patterns match against the URLs being spidered.

                  You are obviously spidering the domain / folder,
                  http://www.cgaconference.com/damagepreventionprofessional.com/

                  It doesn't matter what pages are on any other domain.

                  But if you index the site at its proper location, then it should work just fine.

                  Tip: You don't need to include "http://www." or "*.*" either. There is automatic substring matching. Just using damagepreventionprofessional.com would be enough.

                  Comment


                  • #10
                    Please help future users on the following. it took me WAY too long to figure out.

                    1. If you are going to have external links (websites) as categories, you have to set up the spider to go
                    to those sites. May be obvious to others, but it was not obvious to me.
                    In the categories documentation, you should specifiy that if you are doing external urls,
                    you need to configure multiple start places for the spider.

                    Comment

                    Working...
                    X