Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Submitted search terms from search page overridden by query string search terms

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Submitted search terms from search page overridden by query string search terms

    First, great product! Second, I'm currently testing the free version on my company's dynamic website to see if we want to switch our current search engine to the enterprise version of your product. So far I have everything setup and working well except for one issue.

    The site is .NET 3.5 framework. I'm using a custom search page (default.aspx), inside my Search folder, with the embedded CGI code added per manual instructions. I modified the CGI search page template to display the following layout on my search page:

    Code:
    <!--ZOOM_SHOW_HEADING-->
    <!--ZOOM_SHOW_SUMMARY-->
    <!--ZOOM_SHOW_PAGESCOUNT-->
    <br />
    <!--ZOOM_SHOW_PAGENUMBERS-->
    <!--ZOOM_SHOW_RESULTS-->
    <!--ZOOM_SHOW_PAGENUMBERS-->
    <br />
    In my site header, I have a search box and button which submits search terms to my custom search page and displays the results just fine. I also have a search box and button on my search results page so users can reenter search keywords there instead of having to go back up the site common header. When I submit the keyword search from the results page box, the displayed results are still based on the query string keyword results from the site header search box. How do I resolve that issue and get the search results page search submission to update to the new keyword search?

  • #2
    Thanks for the positive feedback.

    The problem might be because the results search form is within an outer <form>...</form> tag that is enclosing the page. Check the "View source" on the page to see what's happening.

    If this is the case, replace the search form with this:
    http://www.wrensoft.com/zoom/support...tml#searchform

    You can disable the generated search form in the indexer configuration, "Configure"->"Search Page"->and change the search form dropdown box from "Advanced" or "Basic" to "Do not generate".
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Originally posted by Ray View Post
      Thanks for the positive feedback.

      The problem might be because the results search form is within an outer <form>...</form> tag that is enclosing the page. Check the "View source" on the page to see what's happening.

      If this is the case, replace the search form with this:
      http://www.wrensoft.com/zoom/support...tml#searchform

      You can disable the generated search form in the indexer configuration, "Configure"->"Search Page"->and change the search form dropdown box from "Advanced" or "Basic" to "Do not generate".
      Sometimes when you've stared at code so long, it's easy to miss the simple things. Thank you very much, that solution worked perfectly. I wasn't even thinking the issue could be resolved outside the template tags solution.

      Comment


      • #4
        Thank you very much Ray, that solution worked perfectly. Sometimes when staring at code too long, the simplest solutions escape us and a fresh pair of eyes help look at the issue helps a lot. Was stuck on trying to solve it using the template tags and wasn't thinking outside the box. Thanks again.

        Comment

        Working...
        X