Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Automatically delete from existing index

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Automatically delete from existing index

    I have my indexer scheduled to run automatically each week. The only problem is that I must remember to go in and delete a number of pages from the index. I'd like to somehow do this automatically.

    My website contains online help files. The webnav.html page contains the TOC and the indexer uses this to find all of the pages. I need it to be included in the indexing, but not in the final index as the TOC should not be included in search results. So, including it on the Skip Options tab excludes the bulk of my site during indexing.

    Is there a way to automatically remove the webnav.html pages after each time it indexes?

  • #2
    Presuming the "webnav.html" page is your Start Spider URL, click on the "More" button next to it, then "Edit". You will now be able to change the spidering option for this URL. Select "Follow links only".

    Zoom will now only follow the links from this page, but not index the page itself.

    Other strategies that achieve a similar thing would be to use a robots meta tag or robots.txt file to indicate "noindex".

    Hope that helps.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Thanks, Ray! I tried the noindex meta tag, and I'm still seeing webnav.html pages returned in my search. Am I doing something wrong here?

      You can check it out, if you want. Go here: http://resources.arcfmsolution.com/zoom/search.cgi
      Search for "ohda"
      Toward the bottom of the search results, you'll see a couple "No Title" entries. Select either of these.
      View Page Source on the webnav.html page and see the NoIndex meta tag I added.

      Comment


      • #4
        Did you re-index after adding the noindex meta tag?

        Did you upload the new index files after re-indexing?

        You should also check the option to "Reload all pages (do not use cache)" under "Configure"->"Spidering options" to avoid indexing from an older cached copy of the page (before the meta tag was added).

        Let us know if you've tried the above and it is still appearing.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          It seems to be working now. I suspect the spidering option was the culprit. It's all good now. Thanks for the help!

          Comment

          Working...
          X