Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

No results shown with PHP upgrade

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No results shown with PHP upgrade

    A client upgraded the PHP on his server to 5.4. Zoom now shows no results. Host is Verio.

    Any suggestions?
    Gary Kopycinski
    eNews Park Forest, Inc.
    http://www.eNewsPF.com

  • #2
    Could be lots of reasons.
    Hard to tell without looking at the site.

    Might be a resource problem, like this one.

    Comment


    • #3
      Originally posted by wrensoft View Post
      Could be lots of reasons.
      Hard to tell without looking at the site.

      Might be a resource problem, like this one.
      http://www.hhhincorporated.com/

      Error shown is here:

      Internal Server Error

      The server encountered an internal error or misconfiguration and was unable to complete your request.
      Please contact the server administrator, webmaster@hhhincorporated.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

      More information about this error may be available in the server error log.

      Apache/1.3.42 Server at hhhincorporated.com Port 80

      Error also happens on all of the site's contact pages, e.g.:

      http://www.hhhincorporated.com/catalog-sample-request.php
      Gary Kopycinski
      eNews Park Forest, Inc.
      http://www.eNewsPF.com

      Comment


      • #4
        There are backwards compatibility issues with Zoom 6 and PHP 5.4

        I learned this much so far...

        PHP 5.4 does away with Magic Quotes functions, get_magic_quotes_gpc(), etc.

        Zoom's search.php uses Magic Quotes functions.

        There are other issues, I'm sure, as well.

        My client is going to roll back to 5.3. But we will need a solution for the move, eventually, to 5.4:

        http://www.php.net/manual/en/migration54.incompatible.php
        Gary Kopycinski
        eNews Park Forest, Inc.
        http://www.eNewsPF.com

        Comment


        • #5
          Are aren't aware of any problems. Considering that PHP 5.4 has been available for more than 18 months I think we would be aware of any issue before now. PHP V5.5.4 is the current release.

          Maybe you are using an old version of Zoom?

          Comment


          • #6
            Originally posted by wrensoft View Post
            Are aren't aware of any problems. Considering that PHP 5.4 has been available for more than 18 months I think we would be aware of any issue before now. PHP V5.5.4 is the current release.

            Maybe you are using an old version of Zoom?
            I show that I'm using 6.0 (Build 1027)

            The client backed down to PHP 5.3. Now we get the following error on the search.php home page:

            Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'GMT/0.0/no DST' instead in /usr/home/hhhin1/www/htdocs/search/search.php on line 3039

            Site is here: http://www.hhhincorporated.com/search/search.php?zoom_query=best&submit=Search+Site
            Gary Kopycinski
            eNews Park Forest, Inc.
            http://www.eNewsPF.com

            Comment


            • #7
              easy fix with 1 line in htaccess - SET ENV one of these

              Code:
              US America/New_York
              US America/Detroit
              US America/Louisville
              US America/Indianapolis
              US America/Indiana/Marengo
              US America/Indiana/Knox
              US America/Indiana/Vevay
              US America/Chicago
              US America/Menominee
              US America/Denver
              US America/Boise
              US America/Shiprock
              US America/Phoenix
              US America/Los_Angeles
              US America/Anchorage
              US America/Juneau
              US America/Yakutat
              US America/Nome
              US America/Adak
              US Pacific/Honolulu
              ie SET ENV US America/Denver

              If that doesn't work try php_value date.timezone "America/Denver"

              Comment


              • #8
                Your server is not being configured properly for PHP. There are a multiple number of problems with the setup of PHP on your server. Is this being done by your web hosting company or yourself?

                When you described that your earlier "Internal Server Error" is happening here:

                Originally posted by frodojrr View Post
                Error also happens on all of the site's contact pages, e.g.:

                http://www.hhhincorporated.com/catalog-sample-request.php
                This is definitely not caused by Zoom. These are your own PHP scripts which are not working so there's something likely wrong with the configuration (or your PHP pages).

                When you noted this:

                Originally posted by frodojrr View Post
                I learned this much so far...

                PHP 5.4 does away with Magic Quotes functions, get_magic_quotes_gpc(), etc.

                Zoom's search.php uses Magic Quotes functions.
                This is not correct.

                Zoom does not use Magic Quotes function.

                The only way Zoom uses get_magic_quotes_gpc() is to check if the function exists. There is special code to handle specifically this situation (i.e. running newer versions of PHP which does not have magic quotes). As documented here, the "get_magic_quotes_gpc()" function will "always return FALSE" in PHP 5.4 or later. This is what Zoom checks for.

                So I don't think the earlier reported "Internal Server Error" when you had PHP 5.4 or earlier was due to magic quotes. This might have been the reason your pages were not working with PHP 5.4 but it doesn't necessarily mean that's Zoom's problem as well.

                Originally posted by frodojrr View Post
                My client is going to roll back to 5.3. But we will need a solution for the move, eventually, to 5.4:
                We've just loaded up a search page and index right here on a PHP 5.4 server and it worked without problems.

                So the problem is something else.

                You need to enable error messages if it was not displaying before. If you can show us some error messages, we may be of help. Or something else is more messed up if all your PHP pages were showing up "Internal Server Error", that is likely unrelated to Zoom. You may need to look at the Apache logs.

                Originally posted by frodojrr View Post
                The client backed down to PHP 5.3. Now we get the following error on the search.php home page:

                Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'GMT/0.0/no DST' instead in /usr/home/hhhin1/www/htdocs/search/search.php on line 3039
                This warning means your PHP configuration is incomplete, and you have not specified a timezone for your server. Please refer to PHP setup guides for more information.
                --Ray
                Wrensoft Web Software
                Sydney, Australia
                Zoom Search Engine

                Comment


                • #9
                  Originally posted by Ray View Post
                  Your server is not being configured properly for PHP. There are a multiple number of problems with the setup of PHP on your server. Is this being done by your web hosting company or yourself?

                  When you described that your earlier "Internal Server Error" is happening here:

                  This is definitely not caused by Zoom. These are your own PHP scripts which are not working so there's something likely wrong with the configuration (or your PHP pages).


                  This warning means your PHP configuration is incomplete, and you have not specified a timezone for your server. Please refer to PHP setup guides for more information.
                  Just heard from the client, "Per verio and double checked by searching for function on google, you have to add this function to the php code. Apparently this is a php programming requirement since php 5.1.0."

                  I have a managed server with another host and never ran into any problems. I did not install PHP on this client's server. Do I have to add "timezone" to every individual page? Seems to me that's something the host should have taken care of. My server is set to America/Chicago. That setting is in my WebHost Manager, above all other hosting accounts.

                  Thank you for the responses. This is very frustrating.
                  Gary Kopycinski
                  eNews Park Forest, Inc.
                  http://www.eNewsPF.com

                  Comment


                  • #10
                    I dropped the following in as the first line of search.php:

                    date_default_timezone_set('America/Chicago');

                    Works. Tried setting the timezone via php.ini with no luck.
                    Gary Kopycinski
                    eNews Park Forest, Inc.
                    http://www.eNewsPF.com

                    Comment


                    • #11
                      As johan suggested above, using a ".htaccess" file would be better. Otherwise you would need to add that to every PHP page on your site.

                      Your client claiming that calling the function is a "PHP programming requirement" is wrong. That is about the worst way to amend that problem. It works but it's a band aid. That's like saying the band aid is mandatory.

                      The requirement is a setting specified either in php.ini, or in the .htaccess file which indicates what the timezone is. It should not be specified on a page to page basis. After all, your timezone does not change from page to page.

                      More info:
                      http://stackoverflow.com/questions/1...t-timezone-set

                      Originally posted by frodojrr View Post
                      My server is set to America/Chicago. That setting is in my WebHost Manager, above all other hosting accounts.
                      Some info on where the setting might be found in WebHost Manager:
                      http://forums.cpanel.net/f5/changing...el-313752.html

                      Originally posted by frodojrr View Post
                      Tried setting the timezone via php.ini with no luck.
                      Make sure you're editing the correct php.ini file. There's only one copy of the file that's actively being used by the PHP instance, and sometimes there's multiple copies on a server.

                      If you're on shared hosting and via something like WHM, then it's even more likely that's not the global setting file you'd have access to. So try the .htaccess approach as mentioned above.
                      --Ray
                      Wrensoft Web Software
                      Sydney, Australia
                      Zoom Search Engine

                      Comment


                      • #12
                        For what it's worth, it fixed the same problem with me and I'm on shared hosting

                        Comment

                        Working...
                        X