Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Help me troubleshoot malformed Titles in the search results.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help me troubleshoot malformed Titles in the search results.

    Here is a sample copy of what I have Zoom indexing:

    <head>
    <title>Mitsubishi Motors Research & Development of America, Inc. located in Ann Arbor, Michigan</title>
    </head>
    <body>
    Responsible for the design and engineering of Mitsubishi products for the American market.
    </body>
    </html>

    Here is the same information in the search results:

    Motors Research & Development of America, Inc. located in Ann Arbor, Michigangan
    ... Mitsubishi Motors Research& Development of America, Inc. located in Ann Arbor, Michigan ...

    Here is the page source:

    <div class="result_title"><a href="http://automotiveoem.com/Mitsubishi-Motors-Research-and-Development-of-America-Inc_9994.htm" >Motors Research & Development of America, Inc. located in Ann Arbor, Michigangan</a></div>
    <div class="context">
    <b>...</b> <span class="highlight">Mitsubishi Motors</span> Research& Development of America, Inc. located in Ann Arbor, Michigan <b>...</b></div>

    There are two (2) major problems:

    1) "gan" is appended to Michigan (highlighted in red above)

    2) "Mitsubishi" is missing from the Title (highlighted in blue font in the original file and below). We should have:

    "Mitsubishi Motors Research & Development of America, Inc. located in Ann Arbor, Michigan
    ... Mitsubishi Motors Research& Development of America, Inc. located in Ann Arbor, Michigan ..."

    and not:

    "[missing text] Motors Research & Development of America, Inc. located in Ann Arbor, Michigangan
    ... Mitsubishi Motors Research& Development of America, Inc. located in Ann Arbor, Michigan ..."

    I'm wondering whether the 'ampersand' (&) is causing the problem somehow, but if not then there is definately a bug or at least something I'm missing.

    I appreciate your help, thanks!

    David

  • #2
    What version of Zoom are you using?
    Is this running on a Linux or Windows server?
    What script are you running (PHP, ASP, CGI, etc..)?
    How to you transfer the index files from the machine doing the indexing and the web server?

    There is some chance it is index corruption. Did you try deleting the set of index files and re-creating them.

    Yes, you used an unescaped ampersand "&", which is not correct HTML. It is recommended to use "&amp;" as it is safer. I think it is unlikely this is the root cause of the problem however.

    Comment


    • #3
      Hi I am using Zoom version 6.0 (Build: 1029).
      I'm indexing on a Windows XP Pro 32-bit.
      The web server is running on Linux/Apache.
      The script being used is CGI.
      I haven't 'deleted' the index files, just overwritten them several times (problem persists).
      Would you like me to send a copy of the files?

      Comment


      • #4
        Ok, I've discovered some helpful clues, perhaps.

        If I search for the words "mitsubishi" and "motor" the record Title looks ok, but if I enclose the two keywords with quotes as in "mitsubishi motor" then some of the same records in the search results have the malformed title, others not.

        After some further testing, I also noticed that if the matching keyword is exactly "mitsubushi motor" then the title is formed correctly, but when the matching keyword is "mitsubishi motors" (notice the plural 'motors') then I see the malformed title.

        If I search for "mitsubishi motors" (using the plural form of motor) then everything is fine as well.

        So in summary, the malformed title appearance seems to be related somehow to Zoom's handling of plural word alternatives.

        By the way, I have the 'Allow exact phrase searching when words are enclosed in double quotes' checkbox checked. I also have Stemming enabled.
        Last edited by OC4me; 11-27-2013, 12:33 PM.

        Comment


        • #5
          Yes, zip up the set of index files and EMail them to us.

          Comment

          Working...
          X