Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

404 error on search.cgi

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 404 error on search.cgi

    My search used to work just fine. I don't know what happened. Now, I get a 404 error when I execute http://www.jayhanson.org/cgi-bin/search.cgi

    I assume that "search.cgi" is trying to load "search_template.html"

    Apache will not allow me to load "search_template.html" from the cgi-bin directory.

    Can you tell me which directory I am supposed to put my "search_template.html" in?

    Thanks,
    Jay

  • #2
    It seems to be the access (or lack thereof) to the search.cgi file that is causing the 404 error. I don't think the problem has anything to do with the search_template.html file. You don't need external direct web access to the search_template.html file, because it is loaded up by the CGI.

    Is this on a Linux / Unix system? Did you check the file permissions on the .CGI file. Does it have execute permissions set?

    See also this FAQ page for troubleshooting the CGI installation.
    http://www.wrensoft.com/zoom/support/faq_cgi.html

    Comment


    • #3
      Sorry! It was a stupid problem.

      Sorry! It was a stupid problem.

      I haven't been able to get Zoom's ftp to work(?), so I have been using Filezilla for the ftp upload.

      After digging around in everything under the sun -- all day long -- I finally discovered that Filezilla defaults ".cgi " files to a text transfer!

      I uploaded search.cgi in binary and it worked immediately.

      Thanks for your time,
      Jay

      Comment

      Working...
      X