Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Zoom Indexer Scheduler job exit code of (4)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zoom Indexer Scheduler job exit code of (4)

    Hi,

    Any idea how i can debug this further? A new windows scheduled task created to update does not look like its ran successfully. This was the new task:-

    "C:\Program Files\Zoom Search Engine 6.0\ZoomIndexer.exe" -s "C:\Documents and Settings\All Users\Desktop\zoom - knowledgebase.zcfg" –update

    In the Windows Scheduled task log it states:-

    "ZoomIndexer Scheduler.job" (ZoomIndexer.exe) Finished 06/10/2014 08:00:02
    Result: The task completed with an exit code of (4).

    Reading other threads, i cannot find a zoomindexer.log in any directories on the server.

    This zoomindexer was just installed on this server last week and the zcfg imported (obtained from the original indexer) so an -update has never ran from this indexer on this server.

    Thanks

  • #2
    This means it is failing to access the ProgramData folder. This is usually:
    C:\ProgramData\Wrensoft\Zoom Search Engine Indexer\

    Check if your scheduler task is running under a different user account than what you have installed it for. And perhaps this user account does not have read and write access to this folder and the files within it.

    As for the log file, you can specify the location of the log file within your .zcfg configuration. Under "Configure"->"Index log"->"Save index log to file"
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Thanks - There was no ProgramData directory structure so i have created it and moved the config file there and imported it again. Now when running this task:-

      "C:\Program Files\Zoom Search Engine 6.0\ZoomIndexer.exe" -s "C:\ProgramData\wrensoft\zoom search engine indexer\zoom - knowledgebase.zcfg" –update

      it briefly shows on the log tab:-

      file not found(C:\Documents and Setting\All Users\ Application Data\wrensoft\zoom search engine indexer\|update) - config file not found
      could not load config file C:\Documents and Setting\All Users\ Application Data\wrensoft\zoom search engine indexer\|update

      and then exits.

      If i just start the Zoom Indexer it shows C:\ProgramData\wrensoft\zoom search engine indexer\zoom - knowledgebase.zcfg loaded successfully on the log tab

      So i have moved the config file to:-

      C:\Documents and Settings\All Users\Application Data\Wrensoft\Zoom Search Engine Indexer\zoom - knowledgebase.zcfg

      (which i have since learned is the correct location for this version of windows)

      changed the task to:-
      "C:\Program Files\Zoom Search Engine 6.0\ZoomIndexer.exe" -s "C:\Documents and Settings\All Users\Application Data\Wrensoft\Zoom Search Engine Indexer\zoom - knowledgebase.zcfg" –update

      It shows the same error:-

      file not found(C:\Documents and Setting\All Users\ Application Data\wrensoft\zoom search engine indexer\|update) - config file not found

      I'm running the task as my own user profile - does it need to be ran with admin privileges?

      Thanks
      Last edited by MartinK; 10-09-2014, 11:12 AM. Reason: more info added

      Comment


      • #4
        Hi,

        I think i have this resolved - Its something to do with the "-" dash key in the run command and the zcfg filename. The task schedule seems to confuse it with a "|". I compared 2 lines in Notepad and the "-" looked different (longer). When i completely retyped it out without copying its now started. Must be something to do with key characters not really my area.

        Comment


        • #5
          Originally posted by MartinK View Post
          There was no ProgramData directory structure so i have created it and moved the config file there and imported it again.
          This is strange. The installation must create the directory structure for all the required files to be available. Did you move or copy this installation from another computer?

          You must install Zoom from the installation package for it to work as intended.

          Originally posted by MartinK View Post
          I think i have this resolved - Its something to do with the "-" dash key in the run command and the zcfg filename. The task schedule seems to confuse it with a "|". I compared 2 lines in Notepad and the "-" looked different (longer). When i completely retyped it out without copying its now started. Must be something to do with key characters not really my area.
          Yes, there is a different hyphen character that some word processing programs (like Microsoft Word) will automatically replace your ordinary "-" with. So if you have copy and pasted the commands through some word processing program, then it's possible it's been modified to the incorrect dash character.
          --Ray
          Wrensoft Web Software
          Sydney, Australia
          Zoom Search Engine

          Comment


          • #6
            Originally posted by Ray View Post
            This is strange. The installation must create the directory structure for all the required files to be available. Did you move or copy this installation from another computer?

            You must install Zoom from the installation package for it to work as intended..
            Yes - it was a completely new instal - but it did create the directory structure:-
            C:\Documents and Settings\All Users\Application Data\Wrensoft\Zoom Search Engine Indexer

            So i guess it depends which version of windows - it works okay using this directory.

            The task now runs and updates the indexes with any webpage amendments.

            "C:\Program Files\Zoom Search Engine 6.0\ZoomIndexer.exe" -s "C:\Documents and Settings\All Users\Application Data\Wrensoft\Zoom Search Engine Indexer\zoom.zcfg" -update

            However, if any completely new html pages are added to the website, it does not add them to the index, it only adds changes to existing pages. Reading through the guide, i cant see how its possible for the -update to add new pages unless they are specified? Is it possible to add new pages with a wildcard e.g *.html? (i.e. without having to specify the new page names?)

            The problem is i have no control over new pages added and so need a process to that just finds them and adds them automatically. I was told the above task was the only one set up by the previous user - brand new pages were indexed daily but i cant see how the above task done it.

            Comment


            • #7
              Originally posted by MartinK View Post
              Yes - it was a completely new instal - but it did create the directory structure:-
              C:\Documents and Settings\All Users\Application Data\Wrensoft\Zoom Search Engine Indexer

              So i guess it depends which version of windows - it works okay using this directory.
              Yes, the ProgramData folder is for versions of Windows from Vista onwards. You must have an earlier version of Windows.

              Originally posted by MartinK View Post
              However, if any completely new html pages are added to the website, it does not add them to the index, it only adds changes to existing pages. Reading through the guide, i cant see how its possible for the -update to add new pages unless they are specified? Is it possible to add new pages with a wildcard e.g *.html? (i.e. without having to specify the new page names?)
              You are using Spider Mode. This relies on following/crawling links from page to page to find pages to index.

              So when you use incremental update, so long as your new pages are linked from an existing page, it should pick up the new page when it proceeds to index the changes to that existing page. Check your log details to see which pages are being detected as changed, and where the links are to your new pages.

              Wildcards etc. won't work with spider mode. You can't find all *.html pages from a web server over HTTP. Just like you can't find all the web pages from cnn.com or similar. You have to have a link to follow.
              --Ray
              Wrensoft Web Software
              Sydney, Australia
              Zoom Search Engine

              Comment


              • #8
                Thanks,

                Each html page is not linked to each other, its more a library than a website. I've changed the schedule so it now just does a full re-index each night as it only takes a couple of minutes.

                I was told by the previous owner that the incremental index spider mode -update was used to add new pages to the site but as they are not linked, i dont think that was correct.

                Thanks for resolving this!

                Comment


                • #9
                  There is also an incremental -addpages parameter to add specific new pages to the index. More details here:
                  http://www.wrensoft.com/zoom/support...mmandline.html

                  Note that it's not so much that each HTML page must link to each other by themselves, but that there must exist a path of links from the pages already in the index, to the new page. This should not be an unusual requirement, otherwise a normal human visitor to the site would not find this new page either.
                  --Ray
                  Wrensoft Web Software
                  Sydney, Australia
                  Zoom Search Engine

                  Comment

                  Working...
                  X