Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Wordpress Plugin Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wordpress Plugin Error

    Hi All,

    I'm currently configuring our v6 on our new site in preparation for migration to v7. Its a Wordpress site and we're attempting to use the plugin.

    The site search page is;

    http://info.bwvint.com/search-engine/
    (link back URL is set to same)

    This is the error we get on the page when doing a search;

    Zoom Search
    Error: Failed connect to info.bwvint.com:443; No error

    Try searching for gold, silver, shipwreck, etc.

    We've had no luck trying to figure it out.

    Thanks in advance for your help!

    Scott

  • #2
    The Zoom Search WordPress plugin uses the wp_remote_get() function from the HTTP API which requires at least WordPress 2.7.0.

    The error message you are receiving is because the function wp_remote_get() failed to send the query to your server because it could not connect. We have not run into this issue before.

    Error: Failed connect to info.bwvint.com:443; (Port 443) usually indicates HTTPS. When I tried to access your search page via HTTPS, "https://info.bwvint.com/search-engine/" or even your homepage "https://info.bwvint.com/" I get a connection time out. This may be related, can you confirm the settings on the Zoom Plugin Page.

    Depending on the protocol used to access the search page, e.g. https:// or http://, the plugin will use the same method when calling the search.php search script when returning the results. Which might differ from the link back URL in this case.

    Comment


    • #3
      Sorry for the problem, here is the URL to the page;

      http://info.bwvint.com/advanced-search-engine

      Comment


      • #4
        Where are the search files from Zoom (e.g. search.php, search_template.html) located on your server? What is the URL?

        If you do not want to provide this information on the message board you can send it in via email.

        Comment


        • #5
          In the root directory "/"

          Comment


          • #6
            1. The Zoom WordPress plugin is used to easily embed the search engine into a WordPress site without having to redo the look and feel for the site. When I go to http://info.bwvint.com/search.php, it seems you have either extensively edited the search_template.html file to mimic your WordPress template or modified search.php. Have you modified our search script, search.php, in any way?

            If so, can you use the default unmodified search_template.html and search.php to test. If you are happy with the way http://info.bwvint.com/search.php already looks and works, you do not need to use the Plug in.

            2. Can you provide a screenshot of your settings screen for the Zoom WordPress Plugin? Similar to what is shown below.



            3. If you are comfortable with PHP, you can edit the Zoom Search plugin file (zoomsearch.php) to display the URL the plugin is calling to preform the search. From within WordPress (Plugins->Zoom Search->Edit) or any text editor. In the "function zoom_search( $atts )" add the following line right before the line "$res = wp_remote_get( $zoom_url);" :

            PHP Code:
            echo $zoom_url
            Load your search page in your browser and determine what URL Zoom is trying to call that is returning the problem connecting message you are seeing.

            Comment


            • #7
              I made sure the default search.php and search_template.html are installed in the root directory along with the index files at http://info.bwvint.com.

              With these settings;



              I get this result;



              With these settings;



              I get these results;

              Comment


              • #8
                Two things; I also disabled all plugins and got the same results and changing the search hook setting makes no difference.

                Comment


                • #9
                  With your "path to index files" set to "/" can you do number 3 listed above? This will allow us to determine what URL the search script is trying to call. If you are uncomfortable with editing the PHP, send us an email referencing this thread and I will send you back the modified plugin script.

                  Comment


                  • #10
                    I did that in the first set of images above. The URL comes back as;

                    https://info.bwvint.com///search.php

                    Comment


                    • #11
                      having the same issue as well. looking forward to the solution.

                      Comment


                      • #12
                        Your site wouldn't perchance be hosted on an IIS server?

                        Looking over the code in the .php file, I was able to locate a situation where there could be an issue when accessing the $_SERVER['HTTPS'] variable on an IIS server. I have updated the Wordpress plugin. Could you please try the updated file. Note: If you have modified the CSS, you can just copy over just the zoomsearch.php file to prevent undoing your work on the CSS.

                        In the Zoom Indexer, your link back URL should be set to http://info.bwvint.com/search.php. You will need to reindex and upload the files. Let us know how it goes.

                        Comment


                        • #13
                          Yes, it is on a IIS server. I'll test the new plugin and let you know the results

                          Comment


                          • #14
                            Just installed the new plugin on our multi-site configuration and its working very well! Whatever you did fixed the problem. I probably should have mentioned the IIS server at the start.

                            Thanks for all your help!

                            Comment

                            Working...
                            X