Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Auto Complete a bit crazy

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Auto Complete a bit crazy

    Auto complete not working right. I thought that if you put in part of a word it would pick it up but it doesn't. It is also picking up things it should not, like the name of a program I use on my home page. It also is picking up the word "forum" which is no where on my site. Also The statement, "where is my post" I am only indexing titles of certain pages. I bought pro version and is the first time I have used auto complete. What I want is if someone puts in EL it will pick up Ellen which is aprt of a title I have indexed. Can you help. Thanks

  • #2
    Can you give us a link where we can see the (non working) auto complete in action.

    Comment


    • #3
      Hi,
      I am only indexing titles in one directory and its sub directories. Have a title in there called "ellenvanin klienen" but I put in "el" it brings up "velvet" which IS part of a title but does not bring up "ellen". If I enter "F" it comes up with "fade in fade out slide show" if I enter "Fo" it comes up with "how to post on forum" If I enter "W" it brings up "where is my post". Now this is all on Firefox. In Chrome and IE it doesn't work at all. here is the link.

      Comment


      • #4
        I checked today.
        You don't have auto-complete enabled on your web site. So the (poor) suggestions you are seeing are from your browser's auto complete function and not from our software.

        From the Zoom User's Guide
        "Autocomplete
        When this feature is enabled, as users type in the search box, a list of suggestions will appear immediately to complete their search query based on your list of words, or popular searches determined from your Search Statistics Log. This feature is also known as "auto-suggest.........Once this is enabled, the next indexing run will create an additional .zdat file ("zoom_autocomplete.zdat") and include a "zoom_autocomplete.js" file and "zoom_autocomplete.css" file. The latter two files can also be retrieved from the "Extras" folder manually (via "Tools" menu -> "Open extras folder")."

        From what I can see on your page, you aren't using our default HTML page, and you haven't included the "zoom_autocomplete.js" and "zoom_autocomplete.css files, into your HTML page.

        Comment


        • #5
          Ok wiped everything of and started over. It generated the autocomplete files and i linked to the autocomplete js and css file but still does not work. By the way your default html page does not have these links on it at all and the default page does not work either. It is configured only for page titles, the zdat file has all the words. Should this file be linked to or just uploaded. I can't find any reference to it any where. Am so frustrated with this.

          Comment


          • #6

            Turns out you are using the Javascript option, which doesn't support Auto-complete. So that is why it doesn't work. I should have realised and pointed this out sooner, my apologies. It can work for PHP (and CGI, ASP, ASP.NET) however, if that is an option with your hosting company?

            Comment

            Working...
            X