Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Filenames don't appear to be indexed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Filenames don't appear to be indexed

    Overall, I'm having good results with testing of the Free version. However, I'm not able to get any of the filenames to return search results even though I have the Filename checkbox selected in the Index Options, and I have all of my filename extensions listed in the Scan Options. For example, if I have a file named: Fixed Segment Cam Simulator.xlsx, if I search on any of those terms, I don't get any hits. Does anyone have ideas on where else I should look to fix this? Thanks.

  • #2
    It's most likely the spaces in the filename giving you grief. You will probably get results if you just searched for:
    simulator.xlsx

    If you have Exact Phrases enabled (setting under "Configure"->"Search Page"), then you can enclose the full filename in quotation marks, i.e.:
    "fixed segment cam simulator.xlsx"

    And it should find the file.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Unfortunately, that option is not available as I'm using the Javascript version.

      I guess I was hoping that the user could search for "simulator" (no quotes), for example, and it would hit on that word in the above filename. It sounds like that's not possible? If ZOOM Search can read the filenames, I'm wondering why it can't index them as separate words?

      Comment


      • #4
        I did some experimenting with the two Excel files that are being missed by the ZOOM indexer. First I tried replacing all the spaces in the filenames with underscores - no difference; then I tried removing the space/underscore so there are no breaks of any kind between words in the filename - still no difference. The log file is stating: Maximum file size exceeded by [filename], even though the file sizes are far below the setting in the configuration file.

        Comment


        • #5
          Originally posted by stealth94rt View Post
          I guess I was hoping that the user could search for "simulator" (no quotes), for example, and it would hit on that word in the above filename. It sounds like that's not possible? If ZOOM Search can read the filenames, I'm wondering why it can't index them as separate words?
          You can definitely achieve this by turning off dots from joining words.

          Under "Configure"->"Indexing options"->"Indexing word rules", uncheck "Dots".

          You will need to reindex for the change to take effect.

          P.S. The "maximum file size exceeded..." error could be due to the fact that the CONTENT extracted from the XLSX file exceeds the file size limit. Excel compresses the content so the XLSX file itself could be smaller than what it stores.

          P.P.S. Also if you have replaced the spaces with underscores, etc. you may have to also uncheck them for indexing word rules as mentioned above.
          --Ray
          Wrensoft Web Software
          Sydney, Australia
          Zoom Search Engine

          Comment

          Working...
          X