Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Date modified issue with php files

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Date modified issue with php files

    I am trying to get Zoom to grab the correct dates for the files on my site but it just won't do it. I am indexing in spider mode and it works fine for the static PDFs etc on the site but won't show anything for my php. I have tried adding the last-modified meta header but it still doesn't show up. The site is cpanel-hosted so I don't have any control over apache or the server headers.

    Example page:
    http://www.gpd-global.com/co_website/news-events-pr-525.php

    Example search:
    http://www.gpd-global.com/co_website/search.php?zoom_query=conformal+coating (above is first result)

    Any thoughts? I also tried doing the .desc file thing but it also isn't working, and it's not clear to me from the documentation if this will work with php files anyway.

    Thanks!

  • #2
    Tested indexing that page from here and Zoom picked up the last-modified date without issue (assuming you have enabled "Date" in "Results Layout")

    I think most likely your problem comes from indexing a cached copy of the page and not refreshing properly.

    Under "Configure"->"Spider options", make sure to check "Reload all files (do not use cache)"

    Let us know if you still have trouble.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Unfortunately the reload all files option is already checked off. I've made a copy and linked to the zcfg file I'm using here: http://smtnet.com/gpd.zcfg

      I am spidering the site on one server and then ftping the output folder contents to the actual web server - is this ok to do? It seems to work fine otherwise.

      Thanks for your help!!
      Last edited by mlerley; 09-11-2017, 11:16 PM. Reason: Link didn't work right and now I can't remove it

      Comment


      • #4
        We tested your configuration and created an index here. Our test index (using your configuration) successfully retrieved the Last-modified dates from those pages without issue and they are shown in the search results as expected.

        However, we noticed the following:

        1) You are using V7.0 build 1004 for Linux. This is rather old. The latest Linux release is V7.1 build 1003 available here:
        https://www.wrensoft.com/zoom/whatsnew.html#linux

        2) While it is not a problem to manually FTP the output folder contents to the actual web server, you will however, have to make sure to upload ALL the required index files (this includes "search.php", "settings.php" and ALL the *.zdat files). If you only upload a subset of the files, then you will be mixing files from different sessions. And this will lead to unexpected behaviour. Also make sure to FTP all files in BINARY mode.

        Typically the Linux version is used on the Linux web server directly so no FTP is required. But it is certainly possible to use the Linux version on a Linux desktop and then upload the files to a Linux web server.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          I had no idea the version I was running was so old - guess I haven't been paying attention! I updated it and indeed, it's working just like it should now. Thanks so much for your help!

          Comment

          Working...
          X