Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Spidering and ColdFusion

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spidering and ColdFusion

    Not sure if this is a local condition for me but I've tried to index two sites where the start/default page is a ColdFusion page (.cfm). In both cases ZOOM 7 reports that no file was found to spider from. (Never tried it with V6 so I can.t say if it ever worked) Any suggestions welcome.

  • #2
    Should work fine.
    I did a quick test on a few different .CFM sites with V7 and didn't see any problem.

    In Configure / Scan Options, do you have .CFM as a file extension to scan?
    Could the robots.txt file be blocking the indexing of the site?
    Do you have the URL correct in Zoom?
    Are there any errors in log, besides the message you mentioned?

    Comment


    • #3
      I've verified that I can browse to the sites (here's one http://www.injurynet.com.au/) - there are no exclusions in robots.txt that blocks the ZOOM crawler. CFM was included in my scan options. There are no skips. DL thread #1 sits there for a few seconds reporting a connection but doesn't progress beyond 0% (it aborts indexing). The logs show a warning "Could not download the file: http://www.injurynet.com.au/ [Invalid URL or domain name]". The error log is "No files found to spider from http://www.injurynet.com.au/"

      Comment


      • #4
        That site worked OK for me. A copy of the log is below.

        Maybe you have a firewall blocking the connection.
        Can you E-mail me your configuration file.

        ===== LOG =======

        13:20:28 - Zoom Search Engine Indexer (Enterprise Edition)
        14:20:28 - Version 7.0 (Build: 1003) on Windows 7
        14:20:28 - Copyright Wrensoft 2000-2014 (http://www.wrensoft.com/)
        14:20:28 - Plugin for DOC files found. DOC file support enabled.
        <snip>
        14:20:28 - Config file loaded: C:\temp\slco-version7-2.zcfg
        14:20:33 - Core Engine: Version 7.0 (Build: 1003) on Windows 7
        14:20:33 - Config file loaded: C:\temp\slco-version7-2.zcfg
        14:20:33 - Maximum number of files: 10
        14:20:33 - Maximum file size: 9314304
        14:20:33 - Will scan files with extensions
        14:20:33 - .htm
        14:20:33 - .html
        14:20:33 - .php
        14:20:33 - .asp
        14:20:33 - .cfm
        <snip>
        14:20:33 - Spider from: http://www.injurynet.com.au/
        14:20:33 - Web site URL: http://www.injurynet.com.au/
        14:20:33 - Estimated RAM required during index process: 104453 KB
        14:20:33 - [DOWNLOAD] Downloading robots.txt file found at http://www.injurynet.com.au/robots.txt
        14:20:33 - Initiating HTTP session (thread #1) ...
        14:20:33 - [DOWNLOAD] Downloading file http://www.injurynet.com.au/
        14:20:34 - [INDEXED] Indexing http://www.injurynet.com.au/
        14:20:34 - [DOWNLOAD] Downloading file http://www.injurynet.com.au/index.cfm
        14:20:34 - [DOWNLOAD] Downloading file http://www.injurynet.com.au/about-us.htm
        14:20:34 - [DOWNLOAD] Downloading file http://www.injurynet.com.au/how-we-work.htm
        14:20:34 - [INDEXED] Indexing http://www.injurynet.com.au/about-us.htm
        <snip>
        14:20:34 - [FILEIO] Successfully created all required files

        Comment


        • #5
          Spidering and ColdFusion - Resolved

          You're on the money - firewall issue.

          Comment

          Working...
          X