Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Ver 7 400 HTTP Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ver 7 400 HTTP Error

    I have been using Zoom Search Engine since Ver 4. All versions have produced search results for the following path, but Ver 7 states "Could not download file... (400 HTTP Error)"

    http://dsshome/CalWIN/dir_list.asp?Path=Bulletins_Monthly2013&Title=2013 Monthly Bulletins

    The code within the dir_list.asp file displays a list of files within the directory "Bulletins_Monthly2013".

    Not sure why it's not working now with Ver 7. I've even tried running V6 on an older PC and it works, so it's definitely the new version that's not recognizing this path.

    Please advise! Thanks/Cat

  • #2
    There should be no space characters in URL. They should be percent encoded as "%20". Try replacing that URL with:

    Code:
    http://dsshome/CalWIN/dir_list.asp?Path=Bulletins_Monthly2013&Title=2013%20Monthly%20Bulletins


    And let us know if it still doesn't work.

    We've replaced the HTTP engine (for a number of reasons) and it's possible the previous one (the one that's built into Windows) was automatically error handling space characters, and the new one isn't. Having said that, Zoom should have percent encoded the URLs, but there might be a particular situation that (pun not intended) "escaped" the process.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Thanks Ray! I understand the space issue and have been trying to keep all our webpages named without spaces (using an underscore for the space.) These "special" directories have indexed successfully within all other versions of ZOOM, until now... I'm sure adding the %20 will work, but this would have to be done manually done for all the URLs.

      I did notice, under Indexing options, Indexing word rules, there is an option to rewrite the links. I tried adding a space in the "Find in URL:" field, then %20 in the "Replace with:" field, but this didn't make a difference.

      Maybe the dir_list.asp code might be something to look at....I'll see if something can be auto-adjusted with the code, otherwise, I may have to use the previous version of ZOOM until I've got this figured out.

      Thanks! /Cat

      Comment

      Working...
      X