Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

libcurl.so.4 error (no version information available)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • libcurl.so.4 error (no version information available)

    Hi guys.

    I tried to run the Linux version of Zoom engine on CentOS servers (I've tried both 32-bit and 64-bit systems).
    But I kept getting the below error messages.

    /var/www/html/zoom/ZoomEngine: /usr/lib/libcurl.so.4: no version information available (required by /var/www/html/zoom/ZoomEngine)
    mv: cannot stat `indexlog.txt': No such file or directory
    Error: Failed to create shared memory section (section already exists?): 17
    What could be the reason(s) and solution(s) for this issue?

    Thank you in advance for any assistance.

  • #2
    You will need to install the 32-bit libcurl library for Zoom to run. On some Linux distributions, you may need to install any missing libraries such as libcurl. You can check all the required libraries are available by running the ldd command on the ZoomEngine executable.

    Comment


    • #3
      Thanks for your reply.

      The /usr/lib/libcurl.so.4 file exists, so I suppose libcurl library has been installed?
      I am not sure what is meant by the "no version information available" error. Any idea?

      Comment


      • #4
        Your libcurl may to be built in a way that isn't compatible with what Zoom Linux requires. I would guess the error message refers to symbol versioning, e.g. you are using 64-bit build of libcurl . You may want to locate and install 32-bit version of libcurl. We are currently working on a native 64-bit build of Zoom Linux.

        Comment


        • #5
          What version of CentOS are you using?

          This error message could indicate that the Linux version Zoom was built under could be newer than the one you are using (so while the linked libraries may exist Zoom may be expecting to use functions that are not available in the version you have installed).

          Comment

          Working...
          X