Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Problem to open URL with special german charaters []

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem to open URL with special german charaters []

    Hello,
    we have some problems to open links with German charters [,,]
    the URL from search page is:
    http://127.0.0.1:8091/thb2009tl/veeder%20Root%20CD/Approvals/TueV_Austria/T%C3%83%C2%9CV-A%20EX-94.Y.022X%20complete.pdf
    if you change the URL in the browser to:
    http://127.0.0.1:8091/thb2009tl/veeder%20Root%20CD/Approvals/TueV_Austria/TV-A EX-94.Y.022X complete.pdf
    the link is working...
    If you use the following link with url encoded as %C3%9C the link is working too
    http://127.0.0.1:8091/thb2009tl/veeder Root CD/Approvals/TueV_Austria/T%C3%9CV-A%20EX-94.Y.022X%20complete.pdf

    Is there an existing solution for it?



    Her a babel fish for german charter
    ASCII = Dez.
    Code:
    ue =  = %C3%BC = ASCII (252) = ü
    UE =  = %C3%9C = ASCII (220) = Ü
    oe =  = %C3%B6 = ASCII (246) = ö
    OE =  = %C3%96 = ASCII (214) = Ö
    ae =  = %C3%A4 = ASCII (228) = ä
    AE =  = %C3%84 = ASCII (196) = Ä
    SS =  = %C3%9F = ASCII (223) = ß
    CFG Content
    Code:
    __7_01069805416
    #STARTDIR:T:
    #SPIDERURL:http://www.example.com/
    #BASEURL:/
    #OUTDIR:T:\thb2009tl\zoom
    #SPIDERURLTYPE:0
    #SPIDERURLUSELIMIT:0
    #SPIDERURLLIMIT:0
    #SPIDERURLBOOST:0
    #USE-CRC:1
    #CURRENTMODE:0
    #DLTHREADS:1
    #NOCACHE:0
    #BEEP-ON-FINISH:0
    #THROTTLEDELAY:0
    #OUTPUT:CGI
    #OUTPUT_OS:3
    #ISDOTNET:0
    #DOTNETUSEFORMTAGS:0
    #DOTNETUSEPOSTBACKS:1
    #VERBOSE:0
    #LOGMODE:1
    #LOGOPTIONS:ERROR|
    #LOGWRITETOFILE:1
    #LOGWRITETOFILENAME:C:\ProgramData\Wrensoft\Zoom Search Engine Indexer\temp\indexlogN.txt
    #LOGAPPENDDATETIME:1
    #LOGDEBUGMODE:1
    #LOGHTMLERRORS:1
    #SCAN_NOEXTENSION:1
    #SCAN_UNKNOWNEXTENSIONS:0
    #SCAN_FILELINKS:0
    #SCAN_USELOCALDESCPATH:0
    #SCAN_LOCALDESCPATH:
    #SCAN_ROBOTSTXT:1
    #SCAN_CHECKTHUMBS:0
    #PARSEJSLINKS:1
    #SCAN_ALLEMAILATTACHMENTS:0
    #REWRITELINKS:0
    #REWRITEFIND:
    #REWRITEWITH:
    #INDEXOPTIONS:METADESC|CONTENT|TITLE|KEYWORDS|FILENAME|LINKTEXT|
    #RESULTOPTIONS:NUMBER|TITLE|METADESC|TERMS|SCORE|DATE|URL|
    #USE-UTF8:1
    #CODEPAGE:850
    #USESTEMMING:1
    #STEMALGO:5
    #MAPACCENTS:
    #DIGRAPHS:0
    #MAPLATINLIGATURES:0
    #ZLANGFILE:German.zlang
    #SKIPUNDERSCORE:1
    #SKIPURLCASE:0
    #MINWORDLEN:2
    #FORMFORMAT:2
    #HIGHLIGHTING:1
    #GOTOHIGHLIGHT:1
    #USEXML:0
    #XMLTITLE:
    #XMLDESC:
    #XMLURL:
    #XMLXSLTURL:
    #XML_OPENSEARCH_DESCURL:
    #XMLHIGHLIGHT:0
    #LOGGING:0
    #LOGGING_FILE:./logs/searchwords.log
    #TIMING:1
    #NOCHARSET:0
    #ESCAPEURLSUTF8:1
    #USEUTCTIME:0
    #DEFAULT_TO_AND:1
    #CONTEXTSIZE:30
    #MAXRESULTSPERQUERY:1000
    #EXACTPHRASE:500
    #LINKTARGET:main
    #SEARCHASSUBSTRING:0
    #STRIPDIACRITICS:0
    #NO_TOLOWER:0
    #ZOOMINFO:0
    #USEDATETIME:0
    #DATERANGESEARCH:0
    #DATERANGEFORMAT:0
    #DEFAULTSORT:0
    #WORDJOINCHARS:.-_'
    #ZOOMIMAGE:0
    #USEDOMAINDIVERSITY:1
    #SPELLING:0
    #SPELLINGWHENLESSTHAN:5
    #PLUGINOPENNEWWINDOW:1
    #WIZARD_UPLOADREQD:0
    #REPORTUSEDATES:0
    #WORDWEIGHT_TITLE:3
    #WORDWEIGHT_DESC:0
    #WORDWEIGHT_KEYWORDS:1
    #WORDWEIGHT_FILENAME:0
    #WORDWEIGHT_HEADINGS:2
    #WORDWEIGHT_LINKTEXT:0
    #WORDWEIGHT_CONTENT:-1
    #WORDWEIGHT_DENSITY:1
    #WORDWEIGHT_SHORTURLS:1
    #WORDWEIGHT_PROXIMITY:1
    #USE-AUTH:0
    #USE-COOKIES:1
    #USE-COOKIELOGIN:0
    #BINUSEDESC:0
    #BINEXTRACTSTRINGS:0
    #PLUGIN_DESCFILES:
    #PLUGIN_USEMETA:PDF|DOC|PPT|RTF|SWF|WPD|XLS|DJVU|IMAGE|MP3|DWF|OFFICE|
    #PLUGIN_USETECHNICAL:MP3|IMAGE|DWF|
    #PLUGIN_TEXTONLY:
    #PLUGIN_PDF_USEPASSWORD:1
    訌訌
    #PLUGIN_PDF_METHOD:0
    #PLUGIN_PDF_HIGHLIGHT:1
    #PLUGIN_IMG_MINFILESIZE:5
    #PLUGIN_ZIP_EXTRACT:1
    #MAXPAGES_LIMIT:7500000
    #MAXWORDS_LIMIT:7000000
    #MAXFILESIZE_LIMIT:501760000
    #DESCLENGTH_LIMIT:150
    #OPTIMIZE_SETTING:8
    #EXTENSIONS_START
    .htm|FILETYPE:0
    .html|FILETYPE:0
    .txt|FILETYPE:1
    .php|FILETYPE:0
    .asp|FILETYPE:0
    .cgi|FILETYPE:0
    .aspx|FILETYPE:0
    .pl|FILETYPE:0
    .php3|FILETYPE:0
    .pdf|FILETYPE:5|THUMBSPATH:./
    .doc|FILETYPE:4|THUMBSPATH:./
    .dot|FILETYPE:4
    .xls|FILETYPE:7
    .xlt|FILETYPE:7
    .ppt|FILETYPE:6
    .pot|FILETYPE:6
    .pps|FILETYPE:6
    .docx|FILETYPE:15
    .pptx|FILETYPE:15
    .ppsx|FILETYPE:15
    .xlsx|FILETYPE:15
    .zip|FILETYPE:18
    .swf|FILETYPE:9
    .jpg|FILETYPE:12
    .jpeg|FILETYPE:12
    .jpe|FILETYPE:12
    .gif|FILETYPE:12
    .png|FILETYPE:12
    .tiff|FILETYPE:12
    .tif|FILETYPE:12
    #EXTENSIONS_END
    #SKIPPAGES_START
    #SKIPPAGES_END
    #SKIPWORDS_START
    and
    or
    the
    it
    is
    an
    on
    we
    us
    to
    of
    has
    be
    all
    for
    in
    as
    so
    are
    that
    can
    you
    at
    its
    by
    have
    with
    into
    #SKIPWORDS_END
    #USECATS:0
    #USEDEFCATNAME:0
    #SEARCHMULTICATS:0
    #DISPLAYCATSUMMARY:1
    #RECOMMENDED_MAX:3
    #USEFILTER:0
    #FILTER_START
    #FILTER_END
    #USEAUTOCOMPLETE:0
    #AUTOCOMPLETE_START
    #AUTOCOMPLETE_END
    #USEAUTOCOMPLETE_IMPORT:0
    #AUTOCOMPLETE_IMPORTNUM:500
    #AUTOCOMPLETE_IMPORTURL:
    #SITEMAP_TXT:0
    #SITEMAP_XML:0
    #SITEMAP_UPLOAD:0
    #SITEMAP_UPLOADPATH:
    #SITEMAP_USEPAGEBOOST:1
    #SITEMAP_USEBASEURL:1
    #SITEMAP_BASEURL:http://www.example.com/
    Last edited by Schluej; 07-15-2014, 09:04 AM.

  • #2
    We've reproduced this and confirmed that it is a bug.

    The problem occurs when the base URL begins with "/" or any relative URL (as opposed to a http:// style URL).

    This will be fixed in the next build.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Originally posted by Ray View Post
      We've reproduced this and confirmed that it is a bug.

      The problem occurs when the base URL begins with "/" or any relative URL (as opposed to a http:// style URL).

      This will be fixed in the next build.
      Hello Ray,
      do you have already an idea when the error is fixed?
      At the moment the link from above is coded as this:
      /thb2009tl\veeder Root CD\Approvals\TueV_Austria\T%DCV-A%20EX-94.Y.022X%20complete.pdf

      But %DC is wrong for

      Regards
      Schluej

      Comment


      • #4
        Hi Schluej,

        Make sure to check the option under "Configure"->"Advanced"->"Percent encode URLs in UTF-8". Note that this will only work on Windows 7 or later.

        We've checked that with this option enabled, the link above should be encoded properly. Let us know if you still have trouble.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Hello Ray,
          I confirm positive.
          Regards
          Schluej

          Comment

          Working...
          X