Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Installed Linux Indexer, trouble registering

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installed Linux Indexer, trouble registering

    I've been using your Windows version a long time, and look forward to working with the Linux version of your indexer so I can run it from any computer with web access, and possibly on a schedule using cron. I've got it installed, and am able to save and load .zcfg files, but when I submit my v7 key for registration I get the following error:

    An error occurred while registering the key, no output was detected from Zoom. This could indicate Zoom cannot be executed properly (due to permissions or security restrictions) or has unexpectedly exited.

    Please paste your username and key into the text box below and then click the Register button.


    It's a VPS installation on Digital Ocean where I have shell access. All the files in the installation are set to 755, all the folders to 777, and the owner is Apache, which I believe is what it should be. But I'm pretty new to Linux shell access and might have something set up wrong.

    James

  • #2
    Are you able to run the ZoomEngine executable from the command line, or have you tried launching the free version from the PHP user interface to see if it will execute?

    If it runs from the command line but not the PHP launcher then it sounds like there is a permission problem or another security measure, like SELinux, stopping the PHP from launching an executable.

    We currently know of no workaround or way of configuring SELinux to allow the PHP script to launch an executable like this. This should be less of a problem in the next build however as we have made several changes to allow the ZoomEngine executable to run as a standalone process. So it can be configured from the PHP script and once you have your configuration file ZoomEngine can be setup to run manually or as a cron job.

    Comment


    • #3
      Thanks for responding.

      When I try to launch it from the PHP interface it just displays: Indexer: Waiting

      How do I launch from the command line? Just type sh ZoomEngine?

      I tried that and it reports:

      ZoomEngine: ZoomEngine: cannot execute binary file

      I don't know anything about SELinux, but when I ran the command sestatus, it reported:

      SELinux status: disabled


      Is there anything I need to do in the .htaccess to get ZoomEngine to run from the command line?

      As I said, I'm a bit of a novice here.

      James

      Added: also tried "sh ./ZoomEngine" with the same results.

      Comment


      • #4
        It sounds like you are using a 64bit install of Linux, ZoomEngine is a 32bit only executable so without 32bit libraries installed it won't run.

        Could you please download the latest build (V7 build 1003) and let us know if you're still having the same issue.

        This updated build contains a 64bit build of Zoom (ZoomEngine64) and the PHP script should automatically run the correct one.

        Comment

        Working...
        X