Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Autocomplete results link

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autocomplete results link

    Hi,
    we've just installed the version V7 of the Zoomsearch software and enabled the autocomplete Function.

    After indexing we've test the autocomplete functionality.

    In the zoom_ac_dropdown box find our autocomplete results. So far so good.

    But if we choose a result we will get an href with a hash tag linked to our homepage (example www.inneo.com/#)

    Is that a Bug?
    You can test it on: http://www.inneo.de/search-de/search.php

    Regards
    Holger Ahlrichs

  • #2
    Have not seen this bug before. Can you check the following:
    - Have you modified "search.php", "settings.php" or any of the index files?
    - I noticed that you must have some URL Rewrite rules set up on your server. For example, this URL:
    http://www.inneo.de/search-de/search_template.html
    Should take us to the search template page (assuming "search.php" has not been modified). Instead, the URL is rewritten to:
    http://www.inneo.de/search-de/search-template/

    So I suspect your URL rewrite rules may be affecting things.

    URL rewrite can generally be dangerous (as dangerous as difficult to predict behaviour is anyway) if used too liberally.

    The autocomplete links should simply link to "#" (i.e. <a href="#">...</a>), which is just the current page. This is commonly used for any links that do not take the user to a different page.

    What I noticed is that your autocomplete links however, are pointing to:
    http://www.inneo.de/#

    UPDATE: I just noticed that you have the following tag on your page:
    <base href="http://www.inneo.de/" />

    This is very likely the cause of the # link taking you back to the front page. Would this page work without this base href tag?

    We'll change the autocomplete feature in the next release so that it links directly back to the search page (i.e. "search.php#") to avoid this situation. BASE HREF is not commonly used so this possibility must have been overlooked.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment

    Working...
    X