Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Search results - Adding a # in the link

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search results - Adding a # in the link

    Hi

    We are currently trying to integrate this search with an internal Web Help output. The Web Help is delivering static web pages through a web server, and the domain is resolved internally, so we are using the offline mode for indexing.

    Search results are like the following.


    1. Testing topic
    Testing topic Black White Orange Yellow PDF version for printing " /
    Terms matched: 1 - URL: 18715.htm


    The link is http://emanuals/test/18715.htm.

    But because of how the Web Help works, we want links to include a "#" in front of the page, e.g. http://emanuals/test/#18715.htm.

    Any ideas? We are using ASP.

    Thanks
    David

  • #2
    That's a bit of an unusual request. But try the "Rewrite links" option under "Configure"->"Indexing options" and set it up to replace "/test/" with "/test/#" (for example).

    Note that the "#" character has special meaning in URLs, and your use of it is not normal. So I can't guarantee this will work and not get sanitized to something else.

    The problem is that the # character is normally reserved for anchors, e.g.
    http://www.mysite.com/page.html#section1
    http://www.mysite.com/page.html#section2

    If you have any control over how this works in your Web Help, I would choose a different character to avoid future trouble (if not the above). Unless it's actually exploiting the way hash anchors work on purpose.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Hi Ray

      Thanks for your suggestion. Unfortunately, the rewrite links option did not work.

      The Web Help is generated from an authoring tool (Author-it), so we cannot change the use of has anchors. It uses JavaScript to generate additional navigation items on each page.

      Comment


      • #4
        I just tested the setting here, and it worked in creating URLs with the hash character after the folder name.

        Did you change the suggested setting with the appropriate folder name?

        Can you zip up and send us the following files? Your .zcfg configuration file, the index log (after indexing, click 'File'->'Save index log to file') and your "zoom_pagedata.zdat" file.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Thanks Ray. This has been resolved by updating to the latest build, as you suggested.

          Comment

          Working...
          X