Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Running Zoom on Intranet site using MODx

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running Zoom on Intranet site using MODx

    FYI: I am a complete noob with all this CMS (MODx) and Windows Servers stuff

    I have Zoom setup on a Windows Server 2012 with IIS 8 and my website is constructed in MODx which uses a MySQL Database to retrieve the webpages.

    I'm having a few issues:
    1. right now my search results only display files (pdf, docx etc.)
    2. The "Title" is normally the file name (which I havn't figured out how to change yet)
    3. The results show files that have long since been deleted from the server
    4. I am unable to locate the location it has put my search results log file in. Looking thru the Zoom documentation the only explanation I can come up with is that it wasn't setup correctly or I am running CGI (which is shown on my IIS server dashboard) which requires additional configuration.
    5. When running the indexer I show it to be indexing the webpages (example: http://site/index.php?id=34), but none of these pages are displayed in my search results.

    So, I was hoping someone could help me in figuring out what is going on with this and how I can get it functioning properly, because my users are getting a bit annoyed they can't find the documents they are searching for.

  • #2
    1. You can index more file types by adding them to the extensions list under "Configure"->'Scan options'

    2. The title can depend on the actual title available within the file. If indexing PDF files, select the ".pdf" extension under the above mentioned listed, and click "Configure" and make sure to have "Retrieve internal meta information" selected. Reindex for this to take effect.

    3. Make sure you have re-indexed and re-uploaded your search files to the server. If you are using an index from prior to your deleting the files, then the index will point to your old files.

    4. Is search logging actually enabled? Did someone else set this up for you initially? You can find more information on setting up search logging here:

    5. Again, make sure you have actually updated your index files on the live server. If you still have trouble, zip up your index log ("File"->"Save index log to file") and your .zcfg configuration file and email them to us and we can take a look. Also give us the URL to your search page. You can email us these details if you wish to keep confidentiality.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      4. yes, someone did set this up for me and that person no longer works here so i have no idea how some of this stuff is setup.

      i decided to uninstall the program and reinstall it.

      since my CMS uses MySQL (php) to create the pages, and my indexer is starting my indexing from my wwwroot folder, how would i do my exclusion list so that i don't accidentally exclude the dynamically created files, or an i just over thinking the exclusion list?

      Comment

      Working...
      X