Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Subscript out of range: '2'

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Subscript out of range: '2'

    I am just getting ready to launch a site and did the indexing this morning. All seems well for many searches but once in a while I get this:

    Microsoft VBScript runtime error '800a0009'
    Subscript out of range: '2'
    /Search/search.asp, line 2947

    I did several searches and I have re ran the index and made sure that I moved all the files. As I said it works for most terms but I get the error often enough that I know something is amiss.

  • #2
    A subscript out of range error is typically caused by one of the following:

    (a) You have a corrupt set of index files due to manually copying or uploading the files to your server and omitting some files on overwrite (so you ended up with a mix of files from different index sessions).

    (b) You have a corrupt set of index files due to uploading the files with a third-party FTP program which mistakenly uploaded the ZDAT files in ASCII/Text mode when it should be uploaded in BINARY mode.

    (c) You have modified the ASP files (search.asp or settings.asp) in some way and broken script functionality. Please inform us if the files have been modified in any way at all.

    For (a) and (b) you should be able to fix this by simply re-indexing and re-uploading the files correctly, making sure to upload all the files listed at the end of indexing. Or use Zoom to upload to be sure.

    If none of the above fixes the problem, please check the version and build number of Zoom you are using, on the off chance that you are using an older build which may have had a bug that has since been fixed.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Hi Ray. Thanks for getting back to me. I did several searches before I posted know about A and B issues and I actually do the indexing on the server so there is no upload issues and I have manually deleted everything and re ran the indexing with no change. I also did not modify the search page in any way. I will check the build version tonight but I downloaded directly from the link provided by wrensoft at the time of purchase.

      Comment


      • #4
        If you still have problems with the latest build (available from here) then ZIP up your index files and e-mail them to us, and we can take a closer look.
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Thanks Ray. Downloading the most recent build, recreating my configuration file for the site, and then reindexing seemed to do the trick. No more errors. Thank your for your prompt assistance.

          Comment

          Working...
          X