Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Moodle Searching Problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moodle Searching Problems

    I was looking for search engine for our customers and their moodle site and since Zoom seems to be the best choice I insalled it and tried it on my localhost test site.
    As you see, I set up the correct indexing mode, star directory, base URL and autput category:



    I indexed the basic folders and file names, as described in the FAQ's.
    Because it is just test version, it indexes only 50 pages in the admin folder, but despite that, it has to work normally, here are the results, which I get...



    Can someone say, what kind of mistake I made in the configuration, so Zoom shows me resulst only from the files itself? I would be grateful for support, so would be easier to deside if the full Zoom version will fit our needs.

    Thank you in advance!

    George

  • #2
    The mistake is that you're indexing with Offline Mode. This means Zoom can only access the files off your file system, so it can only see the PHP script code.

    If you wish to index PHP pages, indeed, a CMS like Moodle etc. you need to use Spider Mode, and crawl the website over HTTP. This will allow the PHP scripts to execute properly, and the dynamic pages to be indexed.

    Switch to spider mode, and specify your start URL as something like http://localhost/totara/ (or the start page from which you want the spider to crawl).
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Thank you Ray for the prompt answer,

      I tried it with the spider mode, but it says, that they are "No files found to spider from http://localhost/xxx" and in 1 sec. after starting it aborts the indexing?

      Comment


      • #4
        There should be a skipped message or error before that (on the Log tab make sure to enable "Skipped messages" or "Show all messages").

        This should give you a reason as to why the URL was not crawled. This could be many different reasons such as the URL having no extension and you have not checked the option to "Scan files with no extension" (under "Configure"->"Scan options").
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Thanks Ray, at last it works fine (for the 50 pages, which it scans...). The problem was with the indexing of of /login/, where it just skipped Skipping http://www.totara.local/totara/login/index.php (Blocked by page skip list) and couldn't go further from this point. When I removed /login/ from the Skip Options it started to work fine. I assume, now I have to work with page and folder skipping, in order to make the search results better. (and trying to convince the clients to include this option in their product).

          Comment


          • #6
            If you need to login to see certain content of the site (which you want to include in your search index), then you should setup the Authentication feature.

            If however, you don't need to search any content which is only visible to logged in users, then you don't need to get Zoom to authenticate. You can probably also skip the login page, but make sure the spider still has links that it can crawl to the rest of the site according to the base URL, or use additional start points (clicking on the "More" button).
            --Ray
            Wrensoft Web Software
            Sydney, Australia
            Zoom Search Engine

            Comment

            Working...
            X