Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Custom script source path

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Custom script source path

    Hi, I am using a custom linux_search.cgi that I modified using the SDK on Debian 8. On the Advanced tab, I have the "Custom script source path" checked and and the "Search script path" specified that contains the linux_search.cgi file located on a network drive. When I attempt to upload the files to the server, I receive an error message that "Filename is invalid, unable to find file C:\Documents and Settings\".

    Why is it looking on a local drive for linux_search.cgi when I have specified that linux_search.cgi is on a network drive? Thank you.

  • #2
    Can you clarify if you are using the Windows Indexer or the Linux Indexer? Both are capable of producing an index with the Linux search CGI.

    I could not reproduce the problem using V7 build 1024, Zoom For Windows with the custom script source path specified as a network shared folder.

    It would also help if you can show us the actual log messages in question and/or e-mail the .zcfg configuration file if we need to take a closer look.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Hi Ray,

      I am using the Windows Indexer, I use Debian for editing and compiling linux_search.cgi. I tried reducing the limit to only 1000 files and it worked fine. I am going to try processing the complete file list again and try uploading again.

      Can an option be added in the FTP tab so that uploading the search.cgi file is optional if search.cgi already exists on the server, in the same manner as uploading search_template.html is optional? I don't modify the search.cgi file often and I prefer to upload and test it independently.

      Also, can you allow for the language file in the Languages tab to also be available via a file path? I would like to be able to use an English.zlang that is on a network drive.

      Thank you Ray.

      Comment

      Working...
      X