Home » Forum
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse
No announcement yet.

Limits - Max. file size indexed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Limits - Max. file size indexed

    Version 7.1 Build 1001, Enterprise Edition

    (Default) Limits - Max. file size indexed: 2048 KB (2.00 MB)

    We are indexing pdf files, and have many files that are larger than 2 MB. Is Zoom looking at the actual size of the pdf, or just the underlying text?

    For example, one of the pdfs is 8 MB. When I extract the text using xpdf tools, the underlying text is just 34,791 bytes.

    1. Do I need to increase the "Max. file size indexed" limit to reflect the largest pdf size, or is it okay with the default since the text is much smaller?

    2. Does Zoom give a warning or error if the "Max. file size indexed" is exceeded by one or more files?

    Thanks for the help.

  • #2
    1) Yes, you will need to increase the "Max file size limit" to reflect the actual PDF file size.

    In many cases, such as using spider mode, we need to determine if a file should be downloaded or not, and this is what we compare against.

    2) Yes, an error is given if a file exceeds the max file size limit.

    If you are using the Enterprise Edition, it should be no problem to set the max. file size limit to 8 MB or larger under "Configure"->"Limits".
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment


    • #3
      Thanks for the reply, Ray.

      We actually are indexing in offline mode vs. spider mode. Does that make a difference?

      I just indexed again. I did not see any errors regarding the pdfs that are larger than the default limit of 2 MB (about 2/3 of the files in the current dataset), and the expected number of files show as indexed. Some of the pdfs that we index are very large (even larger than the 8 MB file mentioned earlier). If we definitely get an error when a file exceeds the max that Zoom can handle, though, I think we'll be okay.

      I did see this error in the log:

      08|03/29/16 08:21:05|Failed to open .ini file (C:\ProgramData\Wrensoft\Zoom Search Engine Indexer V7\zoom.ini)

      The file "c:\ProgramData\Wrensoft\Zoom Search Engine Indexer V7\zoom.ini" does exist and I can open it with a text editor. We did recently purchase and install the Enterprise Edition. Any thoughts as to why I am seeing this error and/or how to fix it?

      Thanks,
      Barbara

      Comment


      • #4
        You should set the Max. file size limit to the largest size of the file you are expecting to index. If you have 8 MB files, then you should set this to 8 MB or larger. You don't have to wait for the error to appear. It will use a bit more memory, but shouldn't be a problem in the cases we're talking about.

        The .ini file error could be related to the user account that Zoom is running under. It may not have permission to access the file. Or you may have anti-virus / security programs running that (incorrectly) prevent Zoom from accessing the file.

        Make sure that you have read AND write access to the file. Make sure the file permissions permit the user in question (let us know if you are running Zoom via some special means, e.g. scheduled, or via an automaton in some way).
        --Ray
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine

        Comment


        • #5
          Sorry, but I finally got back to this and wanted to confirm that it was a permissions problem for the log error, as you indicated:

          08|03/29/16 08:21:05|Failed to open .ini file (C:\ProgramData\Wrensoft\Zoom Search Engine Indexer V7\zoom.ini)

          In Windows 10, I didn't have write permission as a user. I was able to change this with Properties > Security, changing my User permissions to match the System and Administrators settings.

          Thanks for the info.

          Comment

          Working...
          X